problem with updating to the new wordpress

hi I tried to update my plugins and the new wordpress and it wont let me do it . I got this error message saying could not create directory. pls advise

  • Adam Czajczyk

    Hello Jacques,

    I hope you're well today and thank you for your question!

    The error message means that the folders of your WP installation are "write protected". In case of servers that means usually that the folder permissions are too strict.

    Each folder in Unix environment (e.g. Linux based server) has a an owner (that's a "user" account that's assigned to this folder), a group (it's a "group of users" that the owner belons to). This is normally nothing you should worry about but it's good to know that while "owner" and group is "local" to the server there's all third group that could be referred to as "everyone else".

    Then, each folder can have "read" (4), "write" (2) and "execute" permission or any combination of this. These permissions are set separately for owner, group and "everyone else" so if they are set e.g. to "read" WordPress won't be able to update.

    You will want to access your site via FTP (or cPanel "File Manager") and make sure that the folders of your WP installation are set to "755" permissions (which means: read+write+execute for owner, read+execute for group and everyone else). These are "default" permissions though they may be altered by either the server or some security related plugin.

    Try setting these permissions to 755 and hopefully this should let you update the site.

    Let me know how it went please.

    Best regards,
    Adam

  • Dimitris

    Hey there jacques,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Have you checked the "755" permissions in your WP installation already like my colleague Adam mentioned before? Please advise!
    Reference: https://codex.wordpress.org/Changing_File_Permissions#Using_an_FTP_Client

    Could you please access your server through FTP, edit the wp-config.php file and add the following lines just above the /* That's all, stop editing! Happy blogging. */ comment (if not already there):

    define( 'FS_CHMOD_DIR', ( 0755 & ~ umask() ) );
    define( 'FS_CHMOD_FILE', ( 0644 & ~ umask() ) );

    Then try to update WP once more.
    Reference: https://codex.wordpress.org/Editing_wp-config.php#Override_of_default_file_permissions

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.