Problem with user based taxonomy and visibility settings

Hi there. I found a bit of PHP script I have implemented that allows me to assign a user a taxonomy of my own making.

I'm trying to utilize it in a sidebar I've called "epl10001".

When I do the visibility settings in two of the widgets, (Jetpack Image and Custom Menu), the widgets don't show when I log in under the username assigned to that taxonomy as they should. Can you help?

Also, have you experienced modals not being able to be utilized via shortcode in a text box in your custom sidebar plugin? Please advise.

Thank You!!

  • Tyler Postle

    Hey Michael,

    Hope you're doing well today!

    Thanks for your question. I logged in and took a closer look, thanks for granting access there. I checked out the widget you have only for the el pollo loco user role and it seems to show up fine. I have attached a screenshot to illustrate.

    Is this not what you were wanting? I notice you mention attaching a taxonomy to the user. In the sidebar widget I just see a custom user role attached to it, sorry if I'm misunderstanding there. I did verify that the Jetpack image only shows up if you are logged into the el pollo loco user role.

    Also, have you experienced modals not being able to be utilized via shortcode in a text box in your custom sidebar plugin? Please advise.

    Do the shortcodes work normally? When they aren't in a custom sidebar? This could be that your theme doesn't support shortcodes in your sidebar.

    If that's the case then you can add this code to your themes functions.php:

    <?php add_filter('widget_text', 'do_shortcode'); ?>

    Look forward to hearing back Michael!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.