problems adding 7990 users to a group

I sent a newsletter to all active users once, some people unsubscribed, now I want to send another but not to the unsubscribed. If I send to all active users again will people who unsubscribed last time receive? Seems like send to all active users would ignore the unsubscribe status. It seems the way to do it would be to send to a group instead. Maybe I'm wrong?

So, I am trying to add all current users(7990) who aren't already subscribed to the group(another 484 were auto subscribe when they joined since I installed the plugin)or unsubscribed last newsletter(53). I displayed all ungrouped, checked off all except the ones(53) who were listed as unsubscribed, and selected add to group, chose the correct group and hit apply. It's busy for a few seconds and then loads a default enewsletter members settings page.

Notes: It does initially take a while for the list to load all 7990 when I first chose to display all but it completes no problem. It was a huge pain in the ass to scroll through all 7990 and uncheck the unsubscribed ones to make the group perfect. Thankfully I was able to hit back and have an open tab with the full list all checked off correctly, just waiting for the apply button to work.

To my untrained eye it seems related to the large number of users I'm working with? maybe not. Maybe batching the process in chunks of 500 or so is better? Let me know what you guys/gals think.

Thanks as always,
Paul

  • Patrick

    Hi @mcmasterp

    If I send to all active users again will people who unsubscribed last time receive?

    Nope. Not if you check the box labeled "Do not resend..." Also see the note just above that setting (screenshot).

    It seems the way to do it would be to send to a group instead.

    That would also work as users who have unsubscribed from a group are no longer in that group, so they would net receive the newsletter.

    It was a huge pain in the ass to scroll through all 7990 and uncheck the unsubscribed ones to make the group perfect.

    If you want to edit specific groups, you can do that while on the Members page. In the Groups column, simply click any group name to filter the entire list to show only members in that group. Might be a bit easier to unsubscribe users that way rather than scrolling through the entire list. :slight_smile:

  • mcmasterp

    Hey,

    Thanks for the quick reply.

    I see the screenshot but it says "don't resend to people who had THIS newsletter sent to."

    I'm talking about when I send a new newsletter. But I think we would agree that using a group solves this.

    As for viewing group members, I am trying to add ungrouped users to the group. Since it's a one time issue I'm not too concerned. I'm way more interested in why the add to group doesn't work when I add the about 7990 users.

    Thanks again,
    Paul

  • Patrick

    @mcmasterp

    I see the screenshot but it says "don't resend to people who had THIS newsletter sent to."

    Just above that it says "Please keep in mind emails are not being sent to unsubscribed users." So unsubscribed users receive nothing. :slight_smile:

    As for the Add to Group stalling or stuttering with 7990 users, that's an awful lot of back and forth to and from your database. There may be script timeouts, memory issues, etc.

    Have you tested with WP_DEBUG set to true in your wp-config.php? If so, what error messages or notices do you see? Have you also checked your error logs?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.