Problems cloning a site

I need to convert all the sites to a new theme. Managed to create a new site /bolsover-gd in the new theme and now trying to clone this site but getting an error message. (see screenshot) http://screencast.com/t/LT13zseX.
Need help urgently as I have a meeting on Tuesday to discuss this project.
Regards
Tim

  • Nithin

    Hi Tim,

    Hope you are doing good today. :slight_smile:

    Is this issue only specific when you try to clone your /bolsover-gd, or is this a common issue? Could I run a test clone, by creating a new subsite?

    If it's a common issue, could you please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If the conflict test didn't solve your issue, would recommend you to turn debug mode ON. To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please try to clone your subsite. The errors related to this issue, will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, so that we could help get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards
    Nithin

  • Tim

    Hi Nithin

    I've tried several things now to try and clone a site. I managed to clone /nottingham which was one of the old theme sites and the cloned version is /template1 which I've also converted now to the new theme, but when I tried to clone /template1 it failed. However, I would ideally like to convert /bolsover-gd/ as this has css style changes etc.

    So I've tried to clone this again and called it /template2 but it failed. I've left it in that state.

    I added the debug log changes and that file is attached along with the error.txt file found in /home/hangout

    As an added problem, when trying to get the site to connect to our facebook app it fails as well (geodirectory -->social importer --> connect app). Are all these problems connected.

    Desperately need this resolving.

    Regards
    Tim

  • Nithin

    Hi Tim,

    Hope you are doing good today. :slight_smile:

    I checked your website, and tried a test clone, I was able to notice 500 internal errors, when trying to clone a website. This either means, there is a plugin conflict, or you are running out of memory. I was also able to notice that the memory_limit value is showing some random numbers, rather than real values.

    Please check your php.ini file located in your root directory, and check whether you have assigned any wrong inputs. If there isn't any such files, it could be a plugin conflict, and that would explain why your fb app is also not working.

    Would recommend you to disable all the plugins(in network/mainsite), keeping only Cloner plugin enabled, and check whether Cloner works. If it works you can rule out the plugin causing the conflict by following the flowchart as described in this link.

    If you still have issues even after plugin conflict test, would recommend you to increase your memory_limit, you'll have to create a php.ini file in your root directory using a FTP client, and add the following rules to it:

    upload_max_filesize = 200M
    post_max_size = 300M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    For more info please check this link: https://premium.wpmudev.org/blog/increase-memory-limit/

    I added the debug log changes and that file is attached along with the error.txt file found in /home/hangout

    Could you please point where you have included the error.txt, I don't see any file attached in your previous reply.

    Since it's a live website, I didn't perform a conflict test, please let us know how that goes, so that we could help get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Tim,

    So we are facing here error

    WordPress database error Table 'hangout_wp474.dua_56_options' doesn't exist for query SELECT option_value FROM dua_56_options WHERE option_name = 'dua_56_user_roles' LIMIT 1 made by require_once('wp-admin/network/admin.php'), require_once('wp-admin/admin.php'), do_action('load-index_page_clone_site'), call_user_func_array, WPMUDEV_Cloner_Admin_Clone_Site->sanitize_clone_form, WPMUDEV_Cloner_Admin_Clone_Site->pre_clone_actions, WPMUDEV_Cloner_Admin_Clone_Site->create_empty_blog, switch_to_blog, WP_Roles->reinit, get_option

    Those type of errors are usually cause by plugins conflict. Could you confirm that you run plugin conflict like Nithin asked here https://premium.wpmudev.org/forums/topic/problems-cloning-a-site#post-1134153 ? I don't see if you mentioned about results of the test.

    In the meantime - you could try using our snapshot plugin https://premium.wpmudev.org/project/snapshot/ - create snapshot (without user table) of your template site and restore that snapshot on your subsites.

    kind regards,
    Kasia

  • Tim

    Hi Kasia

    I believe the problem lies with the cloner plugin. I installed a different plugin (multisite-clone-duplicator) and it works fine. Tried Cloner again and same problem (nothing appears to happen but creates an usable site which I have to delete. There was a plugin conflict with simple video pro but that has now been disabled.

    I also created a php.ini file as requested.

    So I think the problem lies with cloner as I have now tested the other plugin twice and it worked both times.

    Regards
    Tim

  • Nithin

    Hi Tim,

    Hope you are doing good today. :slight_smile:

    I checked your webiste extensively, there is a conflict in your /bolsover-gd subsite, ie a conflict between your child theme, and the all the active geo directory plugins, which is producing a 500 internal error, not sure what's the exact cause of the issue.

    I was able to clone a subsite /wpfour by deactivating the plugins, and child theme of /bolsover-gd site, and the cloner plugin worked fine, and successfully cloned the website.

    But unfortunately re-enabling these plugins back, generated a fatal error, and the current /bolsover-gd is not accessible, so this was the issue specific to your subsite.

    You'll have to re-name the themes folder under /wp-content/themes using an FTP file, so that we can gain access to your website. If you aren't sure about making these changes, please send us your credentials, so that I could give make your /bolsover-gd website active.

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin