Problems creating the CNAME record with a subdirectory Wordpress Multisite

Hello,

I have a problem configuring the CNAME record at Cpanel, because I have a subdirectory Multisite.

When I'm adding the CNAME record, it asks me for the name field, right? And you say (at the USAGE page) that in here we have to add the subdirectoy of the user, right?

Would be something like:
mymultisite.com/user-directoy/

But Cpanel is giving me an error, because it says:
..................
Name must be a domain with an optional period at the end.
..................

So... how can I configure the CNAME if I don't have a period at the end?

And also, should I remove the default CNAME that the user has at Cpanel?
I mean the following:
http://www.user-domain.com
14400
IN
CNAME
user-domain.com

Thanks,
Francesco.

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for posting on the forums.

    CNAME has only to be added if your client wants to map a subdomain of his domain to a blog on your site.

    If you or your end user wishes to map a sub domain to the blog within your multisite install then you can set up a CNAME

    If he wants to add a domain, then you will need to add an A record as per the usage instructions.

    So if you client blog is

    client.yoursite.com

    Now, if client domain is client.com

    So if he wants to map client.com to client.yoursite.com then he will add an A record
    if he wants to map subdomain.client.com to client.yoursite.com then he will add an CNAME record.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC

  • Shawn
    • The Crimson Coder

    You need to map the A record to the IP of your site or the CNAME to your domain name (NOT THE URL! - DO NOT INCLUDE THE PATH!) and then use the domain mapping plugin to actually map the domain to the specific path. As long as the CNAME/A is set correctly and the domain is mapped in Domain Mapping, the domain mapping plugin will handle the rest.

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for being a great community member.

    We haven't heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is "Not resolved" in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.