Problems with Appointments + after upgrade

Hi -

I added the WPMU Dev Dashboard to this site today, and upgraded to the latest version of Appointments+ (I had previously upgraded to the beta version), and things appeared fine. Settings carried over, confirmed appointments, etc.

I'm now attempting to make a test appointment, but when I click a time slot, the little loading timer just sits and cycles. I never get to the next step.

The page is: http://newyousmilecenter.com/booking

Ideas?

Thanks,
Jon

  • Michael Bissett

    Hey @dawnsinger, hope you're doing well today! :slight_smile:

    It looks like the problem is due to the www. prefix being used interchangeably on the site, given the message that I get inside of Firefox:

    Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://www.newyousmilecenter.com/wp-admin/admin-ajax.php. This can be fixed by moving the resource to the same domain or enabling CORS.

    First, could you try removing the www. prefix from both the "WordPress Address (URL)" & "Site Address (URL)" fields in Settings -> General?

    Also, could you post your .htaccess rules here please?

    Please advise,
    Michael

  • dawnsinger

    Hi MIchael:

    After making the settings changes, it now works.

    Here is my .htaccess file:

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
    # DEFLATE by extension
    AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteRule .* - [E=W3TC_ENC:_gzip]
    RewriteCond %{HTTP_COOKIE} w3tc_preview [NC]
    RewriteRule .* - [E=W3TC_PREVIEW:_preview]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
    RewriteCond "%{DOCUMENT_ROOT}/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html%{ENV:W3TC_ENC}" -f
    RewriteRule .* "/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    RewriteCond %{HTTP_HOST} ^newyousmilecenter\.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.newyousmilecenter\.com$
    RewriteRule ^houston\-booking\-fp$ "http\:\/\/newyousmilecenter\.com\/" [R=301,L]

    RewriteCond %{HTTP_HOST} ^newyousmilecenter\.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.newyousmilecenter\.com$
    RewriteRule ^financing\-options$ "http\:\/\/newyousmilecenter\.com\/" [R=301,L]

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.