Problems with Duplicator Plug-in creating a package so I can start editing offline

Hi There!

So I've been working on a redesign for a site I'm working on: acoustagrip.com. I've done a lot of work on a local server, but I would love to start testing the site on our live server. I'm trying to get the Duplicator plugin working and I'm getting a lot of warnings that the build won't work properly.

When I try the build it fails. I remember reading something about editing something in the php that limits file download size, but I'm a bit wary of going into the php. I don't have a child theme set up yet and I don't want to risk something on a live site.

Any ideas on how I can get duplicator working again? (It did work for me a few months ago and I'd been working on an older version of the site on localhost). I'm looking to get the most up to date version, fix it up and put it up on a test site on a live server.

Thanks in advance for your help!

Regards,

Dakota

  • Michelle Shull

    Hi Dakota!

    I'm not super familiar with Duplicator, but I see a couple of issues that are probably causing you issues.

    The first and third warnings are about the size of your files. As you can see, your site is 254MB, which is 100MB over what your settings allow. Additionally, files over 4MB, which seems large, but isn't that large for a raw image or video file, may trigger timeouts, per this warning.

    The second issue means that you have illegal (read: not readable by all computer systems that may have to read it) characters in some of your file names. Sometimes a caching program might add a query string to the end of a file (tell-tale sign: a question mark in your URLs.) that may be messing with your process.

    To fix it, unfortunately, may involve upping the amount of memory you have available. When I was a noobie and I needed this done, I went to my host.

    Editing these files yourself isn't as scary as it looks, however, and usually only involves adding one or two lines of code. Check out this tutorial, for example: http://docs.woothemes.com/document/increasing-the-wordpress-memory-limit/

    If you try this, do only one step at a time. If your issue isn't solved after trying step one, remove that code and try step two.

    Your wp-config file is in the root directory of your WordPress install, alongside the wp-content, wp-admin, and wp-include folders. Your functions.php file is in the root of your theme folder. Your php.ini file, if you have one, will be in the root of your server. (If that file makes you nervous, ask your host to check/edit it for you.)

    Hope this helps!

    • Dakota

      Hi Michelle!

      Thank you for your response! I think the file names with the issue are actually really long file names created by the CSS Minification in the W3 Total Cache plug-in.

      I've cleared the minify cache in the plug-in and I got rid of all of the active files, but apparently there's an old version of 13 CSS files that doesn't get deleted when you clear the cache because it is still showing up in the duplicator warning. Am I in trouble if I go in and manually delete those files via ftp? Am I going to break something?

      I think I've just found the problem at wordpress.org:

      http://wordpress.org/support/topic/duplicator-is-awesome

      It seems like the W3 Total Cache plugin and Duplicator don't get along. This is very unfortunate because both are very important to the sites I've been working on. I'm hoping that I can delete the W3 Total Cache plugin-create a package in duplicator and then reenable the program. I've found such a remarkable speed increase going from WP Super Cache to W3 Total Cache that I don't think I could go back!

      Thanks for your help, Michelle!

      I checked on the duplicator error log and I actually don't have an upward file size download limit on my server, so that wasn't the problem. It was the long stringed links created by the minification in W3 Total Cache. I'll keep you guys posted about how it works when I try this, hopefully tomorrow!

  • Dakota

    So, here's an update:

    I've tried a couple more things:

    Deleted W3 Total Cache plugin and cleared out all of the long file names. I edited the wp-config.php file to add the extra line of code about the memory limit. But I don't think that worked. Perhaps I need to go back and try step 3 on that article you posted, Michelle! I couldn't find the php.ini file in my install, so I think the 3rd option might be the only thing I haven't tried yet.

    I've contacted my host and also the Duplicator plugin creator because I really need to be able to edit on a test site because we're thinking about pretty radical changes and I can't do them while the site is live!

    I have a couple of screenshots of the error messages that I've gotten posted at:

    http://wordpressjunkie.blogspot.com/2014/09/ive-been-having-issue-with-wordpress.html

    Maybe I'll try showing that article to someone from dreamhost on the line tomorrow. I can't spend any more time on it tonight!

    Any ideas?

    Regards,

    Dakota

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.