Problems with Events+ installation

I have been having trouble installing and setting up Events +. In particular, I can't seem to configure and save any settings. My 'Configure your setting' page gives me these options:

Set your root slug here:
Will you be accepting payment for any of your events?
Allow Facebook and Twitter Login?
Display public RSVPs?
Override default appearance?
Add new field
Field label: Field type: Required?

but there is no way to save any of the changes.

I have tried several times uninstalling and reinstalling the plugin, deactivating all other plugins (except WPMU dashboard) and cleared my browser's cache.

Still nothing changes. Any suggestions? I'm getting very frustrated! :slight_frown:

  • Vinod Dalvi

    Hi @Trish,

    Sorry to hear of the problems you are having.

    Are you not getting "Save Changes" button in the bottom of Events Settings page as displayed in the attached screenshot?

    If it is not displaying then would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    Kind Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi @Trish,

    Thank you for granting me support access.

    I checked your site and found the issue there but it's working fine on my test site.

    Could you please try deleting and re-installing the plugin?

    If it doesn't help you then please try enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you'd like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting!

    Regards,
    Vinod Dalvi

  • Trish

    Hi Vinod

    The errors i'm getting are:

    [01-Apr-2014 18:05:28 UTC] PHP Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /hermes/bosweb/web253/b2536/ipg.12remembercouk/wp-includes/functions.php on line 3049

    Which, having looked through other posts on this error, doesn't seem to be a problem? Or, as Aaron quoted 5 years ago -
    Aaron
    Lead Developer
    "Hey guys, just an update.

    First off this is just a notice meant for developers, doesn't mean anything practically, and you shouldn't worry about it at all. It's just a super annoying thing the BP included in 1.7 unfortunately."

    Any ideas?

  • Vinod Dalvi

    Hi @Trish,

    These are simple PHP notices, it is nothing to worry about!
    Do you have yet WP_DEBUG set to true in your wp-config.php file?
    If you do then please set it to false.

    Try deactivating buddypress plugin.

    I think this is a issue of theme / plugin conflict so to find out you can just try on your development site deactivating all other plugins and using default WordPress theme like Twenty Thirteen as displayed in the flowchart on the following page to know which theme/ plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi @Trish,

    Yes WP_DEBUG is set to true as you asked.

    Please check my recent reply i have told you to set WP_DEBUG to false now so that the notices won't be displayed.

    Also - with regards to the 'flowchart' - the diagram asks:

    Still got the problem? - Yes - Activate one of the previously deactivated plugins - Is the problem back?

    Im not sure that makes sense? If i've still got the problem and I activate one of the deactivated plugins, the problem isn't back! It didn't go away in the first place!

    The further steps displayed in the flowchart will only be applied when deactivating all plugins except the one you are using resolves your issue and this is not the case with you so it means there isn't any theme / plugin conflict in your site.

    After further troubleshooting i found the following error message in your site.

    <script id="eab-arf-additional_fields-template" type="text/template">
    	<div class="eab-arf-field">
    		<b>
    Notice: Use of undefined constant label - assumed 'label' in /hermes/bosweb/web253/b2536/ipg.12remembercouk/wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php on line 155
    label</b> <em><small>(
    Notice: Use of undefined constant type - assumed 'type' in /hermes/bosweb/web253/b2536/ipg.12remembercouk/wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php on line 155
    type)</small></em>
    
    		Required: <b>
    Notice: Use of undefined constant required - assumed 'required' in /hermes/bosweb/web253/b2536/ipg.12remembercouk/wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php on line 157
    <?php echo esc_js(__("Yes", Eab_EventsHub::TEXT_DOMAIN)); ?></b>
    		<input type="hidden" name="eab-arf-additional_fields[]" value="
    Fatal error: Call to undefined function escape() in /hermes/bosweb/web253/b2536/ipg.12remembercouk/wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php on line 158

    It seems from the above error message the JavaScript escape() Function is considered as PHP function which is added in the plugin file in the following statement.

    <input type="hidden" name="eab-arf-additional_fields[]" value="<%= escape(_value) %>" />

    I think this is happening because the ASP style tags has been enabled in your PHP environment.

    Find more information about it on the following page.

    http://www.php.net/manual/en/language.basic-syntax.phpmode.php

    You can just test whether ASP style tags have enabled in your server or not by adding following PHP code in any theme template file, IF it executes then it means it is enabled.

    <% echo 'You may optionally use ASP-style tags'; %>
    <%= 'This is a shortcut'; %>

    If it is enabled then try disabling it by using the solution posted in the following thread.

    http://stackoverflow.com/a/14694376/1287548

    Cheers,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.