Problems with featured image in imported posts

Hi,
I have a problem with the featured image in the imported post. Autoblog is importing the posts but no featured image is set. I am importing post from the main site in my multisite install to a subsite in same multisite.
- Autoblog are activated in subsite and main site feed is added.
- Addons Feature Image Import and Image Import are activated on subsite

I have tried many different solutions:
- Increased memory limit to 256mb
- Added plugin "Featured Image in Rss Feed" to get image added to feed
- Tried both with setting " Use media:thumbnail tag of a feed item" and "Find the first image within content of a feed item", nothing works.
- Since the image are added to the feed within the description I thougt it would work if I selected the setting "Find the first image within content of a feed item" but same result.

My theme (child theme of Ultimatum theme) required the image to be set as Featured image in post to be displayed in a correct way. But the image just ends up in post content.

Why is the addon Featured Image import not setting the image as a featured image in post as the name suggest?

  • Rupok
    • Support Ninja

    Hi Alizon,

    Tried both with setting " Use media:thumbnail tag of a feed item" and "Find the first image within content of a feed item", nothing works

    So sorry to hear the inconvenience you are having. This is really weird and should not happen.

    I tried to regenerate this issue on my test site but I could not. First image from the post content is set as featured image when I select "Find the first image within content of a feed item". So I think, this is your site or RSS feed specific issue.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access.

    Have a nice day. Cheers!
    Rupok

  • Nithin
    • Support Wizard

    Hey Alizon,

    Terribly sorry for the delay, it seems like the support access isn't enabled anymore, could you please enable support access, so that I could give a closer look at your configuration, and see what could be causing this issues. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Alizon
    • Design Lord, Child of Thor

    Hi,
    I have now enabled the AutoBlog plugin again. I have tried antoher plugin since yours didn't work and it has become urgent to find a solution to this problem.

    So please, can you hurry up and find out the problem with your plugin?

  • Nithin
    • Support Wizard

    Hi Alizon,

    Hope you are doing good today. :slight_smile:

    Thank you for enabling the plugin, I tested the feed in my system, and featured image was working fine in it, however I could still see the issue in your site. It seems like the issue is specific to your website, most probably a plugin is causing a conflict, to troubleshoot this further, I would like to run a plugin/theme conflict test as illustrated in getting support manual (flowchart):
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Is it okay, if we could run the test by deactivating the plugins? Which includes deactivating network activated plugins too. Could you please run the test, and see how that goes in your system.

    Please do let us know how you want us to troubleshoot this further, and we'll make sure to get back to you asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.