Problems with google maps in upfront

On my first website:
I changed the google maps widget in upfront to a new region for a google map 100% wide. But i cant get the correct address as it get stuck in Melbourne :S ...

Ive granted access...

  • Sajid
    • DEV MAN’s Sidekick

    Hello rhdawson,

    Hope you are doing good today :slight_smile:

    Its because the maps are not being updated due to Google Maps API key. Google now required a valid API key to allow access to google maps. See the announcement here:
    https://developers.google.com/maps/documentation/javascript/get-api-key

    Please get your google maps API key and add in your main site Dashboard -> Upfront -> General -> API KEYS. Save changes and then add the map and it should work this time :slight_smile:

    Best Regards,
    Sajid

  • Adam Czajczyk
    • Support Gorilla

    Hello rhdawson!

    I just checked some workarounds for it but there's a downside that's causing the map to be "contained" and not "site-wide". I assume that's not exactly what you wish to achieve, am I right?

    In general the workaround is to place the "Map" element on the region instead of setting the map as backround. This would give you an option to drag the map to the proper location. Still though, the map would be "contained" in content width rather than stretched to the full width of the screen.

    This is quite uncommon case and that's why the solution may be quite complex so would this workaround work for you?

    Let me know please.
    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.