Problems with Hummingbird Cache

I am trying to enable caching through Hummingbird. However I am facing this error :
Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
I have set up my own Apache server, so it may well be the case that there is a configuration issue. However I have enabled mod_expires as suggested above and there is nothing additional in my error.log
Is there anything else I can go and look for ?

  • Adam Czajczyk

    Hello Paul,

    I hope you're well today and thank you for your question!

    If you can fully confirm that the "mod_expires" is enabled on your server, it's possible that there's either some "glitch" inside the .htaccess code or that the "mod_expires" requires some additional configuration.

    Could you please share the content of your .htaccess file with me here so I could take a look (I can't do this using support access)?

    Best regards,

  • Paul

    Hi Adam,

    Thanks for your quick reply. After your mail I went back and re-double checked everything to get some screen shots etc.. It turns out that mod_expires was not active. I think I had run 'a2enmod mod_expires' instead of 'a2enmod expires' either that or I had neglected to restart Apache. (Linux Novice here!)

    Either way, after double checking this and re running the commands to get some screen shots I am now able to activate Caching via Hummingbird with no problem.