Problems with importing snapshots to restore sub-sites

Hi there,

I've been trying to import a sub-site from one multisite (www.JustThinkBiG.co) to another (www.ThinkBiGSites.co.uk), which I have done before, and I've experienced two issues;

Firstly, I haven't been able to import the snapshot file directly from Dropbox. I copied the snapshot in question to my public folder in Dropbox but get the error message "Error: Manifest data not found in archive", which suggests that the file isn't accessible from the public folder in Dropbox. Because I couldn't import the file from my Dropbox Public folder, I uploaded it to my site via ftp and then imported it. which leads me to the second problem.

Secondly, the file imports but when I try to restore it, the file name doesn't highlight as a link and I can't select the file to run the restore.

Since I've been playing around trying to restore this snapshot, I've also noticed that the snapshots created and exported to my Dropbox Destination Folder don't appear as clickable links either when I try to restore them. This makes me think that the problem may be a more global issue, rather than a specific one.

Essentially, since I've set up Snapshot on http://www.ThinkBiGSites.co.uk it doesn't look as though I can actually restore any of the snapshots that have been taken.

Your help would be greatly appreciated.

Kindest regards,

Steve

  • Denitsa

    Hello Steve - Think BiG,
    I hope you're having a beautiful day!

    Unfortunately, it is only possible to upload a snapshot from your computer to your server via FTP (like you said you've tried, correct?) and then under Snapshot -> Import enter the full server path to where you uploaded the snapshot in the URL or local path to Snapshot Archive box before clicking Scan/Import Snapshots.

    I recommend uploading to wp-content/uploads/snapshots/ so the file would be automatically found when you press the Scan/Import Snapshots button.

    Also, when you make a new snapshot, what value do you type in the Directory box?

    Can you point to a specific Snapshot that's safe for me to try and restore on your website so I can test that live?

    Looking forward to hearing back from you!

    Cheers,
    Denitsa

  • Steve - Just Think BiG

    Hi Denitsa,

    I've been playing around since emailing you because I've used snapshot quite a few times and not had this problem.

    I've been adding the snapshot using the import function, as you suggest but that didn;t seem to work.

    I've solved my immediate problem by adding a new sub-site to restore to, creating a new snapshot for that sub-site, then re-naming the original snapshot file that I wish to restore (created in a different multi-site), ftp'd the original snapshot to the snapshots folder on the new multi-site, overwriting the snapshot file I created earlier and then restore. That's worked for me.

    If I try to ftp the original snapshot, something's happening that causes snapshot not to 'see' the file or, at least, not to be able to execute and restore it.

    In answer to your second point, I name the Directory that the snapshots go in to for that particular sub-site.

    My main question would be to ask why I'm experiencing difficulty when trying to import a snapshot file from my Dropbox folder?

    As I said in my initial question, if I do that I just get an error message that says, ""Error: Manifest data not found in archive" whereas, previously, the snapshot has imported without any problem.

    Kindest regards,

    Steve

  • Denitsa

    Hey there Steve - Think BiG,

    I logged on to your website, downloaded the Colin B The OFD snapshot, uploaded that to my test server and was able to Import and restore it without any issues.

    Then I made a snapshot consisting only of one database table and set the destination to your Dropbox, but I left the Directory (optional) field blank (as shown in my above post). I was able successfully to restore from it. I left it so you can try that too. Can you also try making a snapshot in the Dropbox without adding a value in this field? It might be an issue with Dropbox folders/permissions.

    Then, when I tried to add a test Dropbox account to your site to test with, I couldn't do that.
    Could you please enable WP_DEBUG to see if there's any related errors?
    Here's a blog post that describes how to do so https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/
    Then, can you try deleting and re-adding your Dropbox account under Snapshot -> Destinations -> Dropbox?

    The log will be saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.

    Keep us posted!
    Kind regards,
    Denitsa

    • Steve - Just Think BiG

      Hi Denitsa,

      Ok, colinbtheofd looks fine. I had to restore the full backup from 24 hours earlier, and had been working on that and other sub-sites, which was one of the issues as i didn't want to lose the work I'd done. Fortunately, my overnight backups happened just before I managed to lock myself out and, with a little jiggery-pokery, I've been able to restore the work I'd done.

      Anyway, I won't be trying to import users with snapshot again.

      Have you any suggestions for another - safe - way that I can import the users from a specific sub-site on my old multisite to the new one?

      That would really be helpful, particularly if I could retain their passwords.

      I'm guessing that the snapshot you created is the WPMU Test Snapshot for Hannah Bimpson - one of my daughter's websites?

      I had done some work on this site and restored it overnight. It looks like your snapshot was taken after I'd restored all the work and, from memory, it looks ok.

      I activated WP_DEBUG mode and deleted my Dropbox Destination and then added it back. The WP_DEBUG Log file is attached.

      Do you want me to switch off WP_DEBUG now?

      Kindest regards,

      Steve

  • Steve - Just Think BiG

    Hello again, Denitsa,

    I've discovered what the problem is with Dropbox - and you may want to let your team know - but on the 15th March they changed the public folder to a standard folder on free accounts and the same will be happening to premium accounts in September, which means you'll no longer be able to import the file from Dropbox, directly.

    I have found a way that's now working - but that was after I managed to somehow erase my login credentials whilst trying to import the users when I restored a snapshot on a sub-site. It really didn't like that and my password and user accounts (I have two) were not recognised, which completely locked me out.

    I restored one of my full backups from the online repository in the hub but, unfortunately, that failed to run properly and restore everything, although it did give me access back.

    I'm now in the process of restoring everything from the individual sub-site backups that I have scheduled over night, every day. Almost done, in fact.

    Kindest regards,

    Steve

  • Steve - Just Think BiG

    Hi Denitsa,

    One further question.

    Thinking about it, I've now restored all sub-sites but not my primary site and it just occurred to me that it may have been better to have restored that one first, because it contains the user tables.

    Would you say that I'm safe to do a restore of the primary site and not lock myself out again?

    To be fair, it's a snapshot that was taken only an hour or so before the problem occurred, which was whilst importing the latest sub-site on the network - manageyourcritic - from my old multisite to this new one.

    Logically, I think it should be fine but I'm very wary after my overnight experience and your thoughts would be appreciated.

    Incidentally, I have noticed one or two minor glitches with user accounts since trying to import the users on that last sub-site and the subsequent restore. Mainly it's involved one user having an incorrect image and being in the wrong sub-site and a second user that did have an avatar but that's now disappeared.

    I'm thinking that this primary restore may well resolve those minor issues. What do you think?

    Kindest regards,

    Steve

  • Nastia

    Hello Steve - Think BiG ,

    Hope all is well!

    My apologies for delayed response. The debug.log file you shared with us doesn't contain relevant information with the issue you are experienced on your site.

    As you mentioned above, the Drop Box policy has been changed and public folders are no longer an option. I've flagged this to our developer's attention.

    I'm thinking that this primary restore may well resolve those minor issues. What do you think?

    When backing up a subsite, if you selected Global Users tables the users of this subsite should be restored as well. Plus, superadmins users are not included when backing up a subsite. This explains why you've been locked up from your site.

    Only the backup of the main site contains all the users' information. Restoring the main site should resolve the issues you have.

    Let me know how it went!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.