Problems with Multi Site subdomain setup

Hi there!

I installed a fresh wordpress copy and enabled multisite option adding wpconfig.php lines and modifying .htaccess.

You can see the installation here: http://www.nflnews.it

After that, I added a wildcard subdomain through cPanel and used "Blogs And Users" plugin for creating a bunch of network blogs which are supposed to be reachable through domains such:

http://dolphins.nflnews.it
or
http://bills.nflnews.it

Unfortunately, I can't get the subdomains to work (I get a 404 error)

I double checked with my hosting provider, and they say every configuration seems ok (which is cool, but doesn't help...)

I must say that the installation IS NOT in root, but in a subfolder like /public_html/myaccount/nflenews.it and this is where my wildcard points to (this is also ok, according to my provider).

Do you have any hint? I'm stuck.

Thank you!

  • PC
    • WPMU DEV Initiate

    Hiya,

    After that, I added a wildcard subdomain through cPanel and used "Blogs And Users" plugin for creating a bunch of network blogs which are supposed to be reachable through domains such:

    First of all, disable all other plugins, they come in picture once we have got the multisite sorted out.

    I must say that the installation IS NOT in root, but in a subfolder like /public_html/myaccount/nflenews.it and this is where my wildcard points to (this is also ok, according to my provider).

    Well, its not advisable to install WordPress in a subfolder but I think by it being installed you mean that you have added a domain to your hosting, which creates a subdirectory for the domain and the actual WordPress install is in the domain root and not a subfolder like

    domainroot/subfolder

    else it will look like yoursite.com/youfolder

    So, the installation location seems fine to me.

    Now coming on to the subdomains not working, it can be one of the many reasons which can cause this to happen and a closer look will be required.

    Can you please send me your login details via our secure contact form

    1: Mark the email to my attention

    Attn: PC

    2: Include a link of this thread in the email

    3: Include FTP and WordPress super admin details.

    4: While filling the form, select "I have a different question" from the list.

    Looking forward for a response on this.

    Cheers
    PC

  • digitalfaber
    • Design Lord, Child of Thor

    Well... I got back to previous settings (i.e. removing A name and adding again DNS wildcard) and... Guess what? It works!

    For sake of clarity: also added a blogs.dir directory within /wp-content (which shouldn't be useful with latest WP MU releases).

    Bye

  • PC
    • WPMU DEV Initiate

    Hey Stefano,

    Thanks for posting back. Sorry for the delay as I was on my day off.

    Glad that its fixed. however I am not sure what caused that to work.

    However, blogs.dir is no longer required on the latest wp releases. Did you by any chance installed WordPress using a auto installer which installed an older version of WordPress and you upgraded it later on ?

    Well, the best part is that its fixed :slight_smile: yay !

    Cheers
    PC
    Sales &Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.