Problems with Multisite

I'm having problems with a multisite site. There must be something wrong in the DB settings.
When I try to change something like updating WordPress it logs me out.
I can't edit my second site (dashboard). I can't even set the language to English for you guys.
I don't know whats wrong.
Is there any possible way you guys can look into this? I have a backup. You can work in live site?

  • Adam Czajczyk
    • Support Gorilla

    Hello Pure Pixels

    I hope you're well today and thank you for reaching us out!

    I checked your site and did some changes in wp-config.php file and the database and it seems to be working fine now:

    I noticed on site and understood from the chat that the site is meant to use "www" prefix but the configuration in wp-config.php and database was a bit "mixed up" for the "www" and "non-www" version. Additionally, the .htaccess contained rules for a regular single WP install and not the multisite one.

    Therefore, I have change "domain" value in _blogs, _site and _options table to use "www" prefixed domain everywhere, consistently. Then I've also changed the DOMAIN_CURRENT_SITE to use www prefix and updated .htaccess to use proper rules for sub-folder multisite install.

    After resetting Authentication and Salt keys in wp-config.php file I was able to login and stay logged in on the site. I tried updating couple of plugins, navigate between sites and network-admin, editing site settings in Network Admin -> Sites -> Edit and so on and so far it worked fine.

    Could you please clear your browser caches, login again to the site and see if it's working fine now for you?

    Let me know, please.

    Best regards,
    Adam

  • Pure Pixels
    • Flash Drive

    Hi Adam,

    Wow! You can't imagine how grateful I am with your support.
    I messed it up really bad. It was my first multisite install.
    I read a tutorial, but obviously I did something wrong.
    Everything seems to work just fine now!

    I have one more question.
    The second site "Vreugdenhil Bouwtechniek" must get mapped.
    I tried using domain mapping. I'm sure there is something wrong there too.
    Would you be so kind to also assist me in this matter?

    DNS is referring to this sever's IP: 185.182.56.40

    The domain name is:
    http://www.vreugdenhilbouwtechniek.nl

    Thanks in advance!

    Regards,
    Jeroen

  • Pure Pixels
    • Flash Drive

    When I try to map it says:

    Domain name is unavailable to access.
    We can’t access your new domain. Mapping a new domains can take as little as 15 minutes to resolve but in some cases can take up to 72 hours, so please wait if you just bought it. If it is an existing domain and has already been fully propagated, check your DNS records are configured correctly.

    But when I check it on mxtoolbox.com it's all ok.

  • Adam Czajczyk
    • Support Gorilla

    Hey Pure Pixels

    I'm glad to hear that you managed to make it work. Just for future reference: to be able to map the domain you need to point that domain's DNS A record to the IP of you site - if you are using a dedicated IP. It's important to remember that such change might take quite a lot of time until it's actually "visible" all over the web.

    If you're not using a dedicated IP (but a shared one, that's used for multiple domains) then you'd rather need to add the domain to the server as an add-on domain and make sure that the root folder of it (aka "document root" - that's the same, just differen terminology) is set to be the same as root folder of the main domain.

    However, since you were able to make it work, I believe you know the procedure now so next domains would work fine :slight_smile:

    In case you had any additional questions or needed more assistance, just let me know.

    Have a great day!
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.