Problems with national characters after moving site to other vserver.

Hi, I'm trying to move my MultiSite to a new server with Ubuntu 14.04LTS und Plesk 12.5. The Pictures in the wordpress uploads contain filenames with national characters. These pictures are not displayed on the new server. (Failed to load resource: the server responded with a status of 404 (Not Found)http://www.elephant-selfstorage.eu/wp-content/uploads/2015/11/Lagerr%C3%A4ume-Berlin-Spandau-mieten-80x80.jpg) In the wp-config the charset ist utf8mb4 and the tables in the database are also utf8mb4. The old Site works fine (http://www.firstelephant.de/wp-content/uploads/2015/11/Lagerr%C3%A4ume-Berlin-Spandau-mieten-80x80.jpg)
How do I have to change the configuration in wordpress, apache and php so that the pictures will displayed ?
Thank for your help. Regards, Andreas

  • Adam Czajczyk

    Hello Anreas,

    I hope you're well today and thank you for your question!

    The file names shouldn't use any special/national characters but unfortunately neither WordPress nor server software doesn't detect and correct it during file upload. Definitely the best solution would be to rename those characters and update WP database entries accordingly so no special/national characters would be used and then take care in future to not use those anymore.

    I understand though that it may be a time consuming task and also especially difficult to handle if more users of your site are allowed to upload files. Yet, this still is the most reliable solution in my opinion.

    A part of it may be simplified, fortunately. After existing images are "cleaned" you could use this plugin to make sure that all newly uploaded files are taken care of automatically:

    https://wordpress.org/plugins/clean-image-filenames/

    Would that be acceptable solution for you?

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Andreas!

    Could you tell me please what was the previous server based on (an OS, a control panel)? Please also let me know how did you moved the site: did you used any tools for this or did it manually or used an assistance of any plugin? Please provide me with as much details on this as possible.

    I'm asking this to better understand what happened here so I could hopefully find a way to solve this in an easier way than renaming all the files and updating database :slight_smile:

    Please advise!
    Best regards
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.