Problems with Network Sites after server migration

I ran a WMPU site on a (dv) 4.0 server (running php 5.2) at MediaTemple and it was working fine. It is a sub-domain network and I was able to get it set up with the wildcard subdomain functionality.

This week they helped me migrate to a new server (running php 5.4) and I have all of the single WP sites running and the main site associated with the MU site, however, I have a problem with the network (sub-domain) sites.

I had to turn off the domain mapping plug-in so that I could get them to work at all, but now when they load, they are really funky – missing most of the styling and formatting.

Here are examples:

http://prsadelaware.38solutions.com/

http://alexcarsoninc.38solutions.com/

http://mainlinejewelers.38solutions.com/

Has anyone encountered this before or have any suggestions?

Getting desperate,

Greg

  • Jack Kitterhing
    • Code Norris

    Hi there Greg,

    I hope you are well today and thank you for your question. Sorry to hear of the issues your having.

    Is domain mapping still disabled? Where do the files reside for the styling on the mapped domain was everything being served from? If it isn’t enabled do you have the defines removed from the configuration file (wp-config.php), what is your .htaccess file?

    Thank you!

    Kind Regards

    Jack.

  • Greg Davis
    • Design Lord, Child of Thor

    Hi Jack – I have kept the domain mapping plug-in turned off (network deactivated) for now.

    The site styling would normally come from the theme that the site is using, correct? Which is strange because some of that is visible but not everything. Also strange is that even when I go to the any of the site WP admin dashboard’s in the network (beside the main site) that is also missing styling. See example here: https://dl.dropboxusercontent.com/u/4138085/WPMU-Site-Dashboard.jpg

    When you ask, “have defines been removed from the wp-config.php” file what lines are you referring to?

    My .htaccess file looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    # Cut down on Comment Spam by denying comments that don?t actually come from your own post referral links.

    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post.php*
    RewriteCond %{HTTP_REFERER} !.*38solutions.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]
    </IfModule>

    # Extra protection to your wp-config.php
    <Files wp-config.php>
    Order Deny,Allow
    Deny from All
    </Files>

    # END WordPress

  • Jack Kitterhing
    • Code Norris

    Hi Greg,

    Thanks for the additional info, much appreciated.

    Some good news is that your .htaccess file is correct, that isn’t a problem.

    With the domain mapping, do you still have define sunrise on, in your wp-config.php?

    That is interesting it’s also like that with the sub domains on the admin area, correct styling would come from the theme, but it looks like it’s having problem loading the styling for the sites and admin, I think this could be domain mapping issue still, would it be possible to re-enable that, then make sure that it’s set to not map the admin area, one that is done, try loading a sub site area and see if it works, if it does disable domain mapping once that is done.

    If you re-name the plugins folder within wp-content, does the styling load? This will deactivate all plugins across the network.

    Please advise.

    Thank you!

    Kind Regards

    Jack.

  • Greg Davis
    • Design Lord, Child of Thor

    Hi Jack –

    The sunrise was still on so I commented out that code as well as renamed the sunrise.php file so it would not be used but no difference in result.

    I also tried renaming the plugins folder and while a few elements disappeared the styling did not come back.

    I also turned domain-mapping back on, replaced the sunrise.php file as well as updated the wp-config.php file so everything was active again – still nothing.

    I decided to have a look at the Chrome inspector console tool as found there are a bunch of 404 error messages for various CSS files. See here: https://dl.dropboxusercontent.com/u/4138085/Console-Errors.jpg

    However, I checked and I do find those files when I browse my directory. See here of example of file highlighted in first screenshot: https://dl.dropboxusercontent.com/u/4138085/Console-Errors.jpg

    So I think the cause of the missing styling are these 404 not found errors on various CSS files. But why would they come up that way when the files are there?

    Confused….

  • Alexander
    • DEV MAN’s Mascot

    Hi @greg Davis,

    I see those sub sites are now redirecting to their associated domains, which in turn are not setup to point to your Worpress Multisite network.

    I actually don’t think this is a problem with domain mapping, but rather with Multisite itself after the site was moved.

    Can we revisit the wp-config.php file? There should be a section that looks similar to this:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'yourdomain.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Could you let us know if you have something like this in wp-config.php, as well as what the contents are?

    Thanks!

  • Alexander
    • DEV MAN’s Mascot

    @greg Davis,

    Think I may have just figured this out. This server is running ngnix. For example: http://jeffream.38solutions.com/wp-content/themes/redtime/style.css

    This means the rewrite rules for Multisite aren’t even being used. htaccess is for Apache only.

    Did your host not make you aware that they’re nginx instead of apache? I would check with them about this. WordPress runs great on nginx, but you’ll need to have the nginx configuration updated to support WordPress multisite. Here’s an article that can help: http://codex.wordpress.org/Nginx

    Best regards,

  • Greg Davis
    • Design Lord, Child of Thor

    Okay – I check with them and they said that:

    the server uses both Nginx and Apache to service web content; Nginx handles the static content and passes requests for dynamic content to Apache.

    Does this confirm what you are thinking?

  • Alexander
    • DEV MAN’s Mascot

    @greg Davis,

    Not quite, because those ngnix files are meant for running WordPress Multisite with PHP-FPM, and they’re meant to run everything not just the static content. You need a special nginx configuration that will proxy for apache, which in turn uses standard PHP.

    You’ll need to see if MediaTemple can fix the configuration for you. This is a pretty advanced server configuration, and is a bit outside of what we can help with through our support.

    If you’re already running nginx, It might actually be worth looking into if you can just use php-fpm instead of apache+php It would be better for performance. Not sure they set things up over there though.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.