Problems with Padding

We are setting up Appointments+ as a single user installation.
There will be three types of appointments available;
* 60 minute appointment
* 30 minute appointment
* 15 minute appointment
We want to add different padding to each of these as an overflow to allow the first client to leave before the next arrives. So the 60 minute appointment will have 30 minutes of padding (60+30=90) at the end, the 30 minute appointment will also have 30 minutes of padding (30+30=60) at the end and the 15 minute appointment will have 15 minutes of padding (15+15=30) at the end.
The end result should be time slots of 90, 60 and 30 minutes.
The problem is that the front-end calendar does not seem to recognize the padding when a user is booking the shorter 30 and 15 minute appointments.
If I book a 60/30 appointment at 9am and then try to book a second 30/30 appointment (or a 15/15) the calendar tells me that the next appointment available is at 10am but it shouldn't allow another appointment until 10:30am. Since this is a single user setup the service provider won't be available until 10:30am. How can we get the front-end calendar to recognize the padding as part of the actual appointment time?
Note 1: We want the client to view the appointment times as 60, 30 and 15.
Note 2: We tried both Shared Resources and a shared Location to try and force the padding to be recognized by the front-end calendar but this didn't work.
Thank you in advance.

  • Juanita

    Thank you Predrag, I now understand the padding has a bug.

    I turned off the padding option and tried setting up 30, 60 and 90 minute services (based on a 15 minute base unit). Depending on which Service type was selected, I expected corresponding appointments to be blocked out but they were not - for example - I booked a 90 min. appointment for 9:00 am, then tried to book a 30 minute appointment for the same day and found that I could book it at 9:30 am, a full hour before the previous appointment would be finished.

    Can you please tell me how to set this up so that booked time slots can not be double-booked?

  • Adam Czajczyk

    Hello Juanita,

    I hope you're well today!

    The I checked your site and you'd need to make some small changes to your setup. Currently all three services there are set to 90 minutes which, I believe, is a "workaround" for a the issue you described in your most recent post.

    Here's what to do:

    1) set service durations for your services like you described: 30 (for 15+15 slot), 60 (for 30+30 slot) and 90 (for 60+30 slot) minutes
    2) set "Capacity" for all these services to "0" (which means "as many available as there are service providers offering this service")
    3) switch off any sharing resources settings and switch off this add-on
    4) go to service providers settings and create one service provider
    5) assign all these 3 services to this single provider
    6) in "Working Hours" make sure that you got working hours properly set for service provider (you need to select that service provider - your only one - from the drop-down list there before settings hours)
    7) Enable "Tetris mode" add-on.

    I've tested this on my test setup to confirm.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.