Problems with ProSites

Hi,

We are experiencing a few problems with ProSites since a client's payment method failed and needed updating.

1. The client updated the payment method for three sites that they have and never received any confirmation. For some reason, the confirmation was sent to the super admin? Also, only 2 confirmations were sent.

2. The data on Stripe for the customer is missing the email and any details of what site is attached to the payment subscription.

3. There is no way to change who the site payment methods get sent to with ProSites, how do you set a primary site admin?

4. Payment failed on one site but when I go to the site settings it says active for another month although in site notes the payments are marked as failed 3 times.

Any advice would be great. Also is ProSites due an update soon its years behind membership pro 2

  • Rupok

    Hi Lakewood,

    Thanks a lot for asking. I'm afraid, I'm not clear about some facts. Can you please help me in understanding those? I can give you better solution if I'm clear about your scenario.

    The client updated the payment method for three sites that they have and never received any confirmation

    Do you mean he paid for three subsites to update those to Pro Sites but only 2 confirmation was sent to super admin? not 3? This is weird, because I just create 3 test subsites in my test multisite but all three emails came to my network admin email. So I'm not sure why this is happening on your site. We need to investigate to find out the reason.

    The data on Stripe for the customer is missing the email and any details of what site is attached to the payment subscription

    Do you mean customer email address is missing? I just created a test site in Pro Sites and then checked Stripe Customers, I can see that user's email address. Am I missing something? And yes, I can't see site url attached to the Payment Subscription in Stripe. But that is maintained in Pro Sites database on our end, not in Stripe end. Do you think Stripe should also have the details of the subsite in Subscription section? I can add that as a feature request if you want.

    3. There is no way to change who the site payment methods get sent to with ProSites, how do you set a primary site admin?

    I'm not sure about how you can set which super admin will get those emails. I'll have to check with our developer. I'll update you regarding this as soon as I get something from him.

    4. Payment failed on one site but when I go to the site settings it says active for another month although in site notes the payments are marked as failed 3 times.

    This is also very weird and I could not regenerate this on my test site.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Lakewood

    Hi Rupok,

    Thanks for getting back to me.

    1. The client has three separate sites and updated the payment method on all three. However, only two emails were sent to confirm the update but these were sent to the super admin, not the client who updated their payment.

    2. When viewing the details on Stripe a new customer has been setup instead of updating the payment methods for the existing customer. We will call the client and manually update the payment methods but this is a bit of an issue.

    3. The client doesn't receive any confirmation emails regards their sites, instead, the super admin receives them. How do we change this so the clients WordPress users get these emails, I've looked in the database but can't find an obvious place to change the user ID associated with managing a site.

    4. The payment failed 3 times which is noted on ProSites and on Stripe on the 15th October but prosites still says the site has prosites status until the 15th November.

  • Rupok

    Hi Lakewood,

    Well, I'm really so to hear that.

    Regarding the email sending issue, I'll have to check with our developer and will update you as soon as I get something from him.

    Regarding the payment failed thing, it's a known issue and our developers are aware about it and working on this. I believe, they will come up with a workaround/solution very soon.

    Now, to investigate these issues, I need to check the issues live on your site. I could tell you better about the issues if I could see these live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hear from you and resolve these issues as soon as possible.

    Have a nice day. Cheers!
    Rupok

    • Lakewood

      Yes and no. There aren't any major issues currently with Stripe but I'm not sure what will happen when someone's card expires again, it is easy to enter a new card details over the phone directly into Stripe but it takes a bit of digging to know what subscription is for what site as ProSites doesn't do a great job of labelling them in Stripe.

      We have a number of sites using Stripe and there aren't actually any issues with month payments, they are taken as expected on the correct dates and also apply coupons correctly.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.