Problems with registration process

Well, I hope that I finally found the right subforum... Okay, once again:

Hi..

First of all, I want to excuse for my bad English. English is not my mother tongue but I hope you understand me.

I use the Membership-Plugin 2.0.3 with the newest version of WordPress. I'm quite sure that I configured everything well. But the registration process doesn't work.

I log out of my admin account and try to register as a new member on this registration page:

http://www.knastinfo.de/mitglied-werden/anmeldung-einmonatskurs

I fill all required fields (username, email address, etc.) and click on "REGISTER MY ACCOUNT". But I don't get to the next page - the registration page simply reloads. I've tried out a lot of things in the last couple of hours - and still I cannot find the mistake.

Possibly some .php-files on my server do not have the right rights. Why do I think that? Well, I have exactly the same installation on an other server - and there it works fine.

Can you please tell me which files inside the membershipincludes-directory are responsible for the registration process? Would be helpful...

Any more suggestions? I appreciate any help! Thanks in advance.

Wittgen66

  • Wittgen66
    • WPMU DEV Initiate

    Hi Barry...

    Thanks for your reply. I'm quite desparate at the moment. :slight_frown:(

    It doesn't look like you are getting any of the error reporting back either?

    Right.

    Just to check through - have you got any subscriptions set up and activated and made public?

    Several subscriptions are set up and made public.

    As I said above: I've installed the plugin on one of my other servers (a different webhost), with exactly the same configuration as here (the same levels, subsciptions, etc.) - and it works over there. But it doesn't work here.

    I think it's got something to do with the rights (CHMOD) of some .php-files. I've already had similiar problems with this host before, and it was ALWASY the rights of the files. So I need to know which files make the subscription process work. Thanks. :slight_smile:

    Wittgen66

  • Wittgen66
    • WPMU DEV Initiate

    I forgot something:

    It's the same problem with the "users/merbers account page" where you put in the [accountform]-shortcode. Nothing can be updated there.

    That's why I think some important .php-files do not have the right permissions (i.e. they are not writable).

    Wittgen66

  • Wittgen66
    • WPMU DEV Initiate

    DavidM said here:

    https://premium.wpmudev.org/forums/topic/problems-with-registration-process#post-97766

    Hi Wittgen66 and welcome to WPMU DEV!

    It looks like there's a bit of a conflict there, either with the theme or another plugin.

    To help rule out the culprit there, can you try deactivating other plugins momentarily to see if that resolves the issue?

    If that doesn't work, can you try switching to Twenty Ten momentarily to see if that resolves it?

    Thanks,
    David

    Thanks, DavidM for your suggestion. That was one of my first thoughts, too, and it's exactly what I tried out (among other things...) before I posted my problem here in the forum. Obviously, it's got nothing to do with other plugins or the wp-theme I use.

    Now it's midnight in Europe and I'm going to bed. Have a nice evening!

    Wittgen66

  • Wittgen66
    • WPMU DEV Initiate

    Hello masonjames,

    yes, the problem has not been resolved yet. It still persists. Even my webhoster is at his wits' end.

    If you need something from me to have a closer look (let's say FTP-data or access to my WP-blog as an administrator), just tell me where to send these infos to.

    Thanks for your reply and your efforts.

    Wittgen66

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.