Problems with registration process for Membership 2 Pro

I thought I had everything working but upon going back to do one last test run before getting our board of directors to test the site I've found the Membership 2 Pro registration process isn't working as expected.

What I expect:

  • visitor goes to memberships page and chooses a membership level and clicks "sign up"
  • visitor completes the registration form and submits
  • visitor is redirected to the payment page (I think is also auto-logged in as part of this step)
  • visitor makes payment
  • visitor gets the auto email welcoming them to the site

What's actually happening:

  • visitor goes to memberships page and chooses a membership level and clicks "sign up"
  • visitor completes the registration form and submits
  • visitor is auto-logged in and redirected to the memberships page (i.e., back to the list of membership levels available)

This is where the 1st problem lies -- they should go directly to the payment page after submitting their registration form rather than have to re-choose the membership level.

The second problem is that if I go ahead and choose again, and then do the payment (in this case using a coupon to make it 100% off), then after submitting the payment page I'm redirected again to the membership list page and it's showing "pending payment".

The third problem is that as a result, the new user is never added to the membership.

The fourth problem is that I'm not getting the proper email confirmation -- I'm getting an email about setting my password instead of the email set in Membership 2 Pro.

I am using BuddyPress in order to create an expanded profile, but I am not using the BuddyPress integration... I am using the Profile Fields addon.

Thanks,
Scott