Problems with Slide in

I can not seem to get slide in to work on my theme which is a custom theme

  • aecnu

    Greetings webimm,

    Thank you for bringing this to our attention and have you contacted the author of the custom theme by any chance to see what they have to say about this obvious theme custom coding issue?

    What is the URL to the page that the slide in should be working on?

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • tishimself

    Hi,

    I am having theme related problems with this plugin on two sites.

    After selecting twenty ten, I noticed some itty bitty social thingy sliding up from the bottom of my screen on the left. And I mean very small.

    I unchecked the Full screen global option and set it to 600px. Then it appeared at the location specified.

    Went back to my themes and no slide in *nothing* for either site.

    One of these themes is an HTML 5 responsive theme not by WPMUDEV, but the other is the Scholar theme. I deactivated the PopOver plugin is used on the Scholar theme, but that made no difference.

    These are WP multisites all at current main levels.

    Larry

  • tishimself

    Hi,

    I upgraded. It does not show on my Home Page.

    I selected "Hide all messages for the visitor" which I thought would make it not display again if the visitor closed it out. But it never seems to quit.

    Is there any way to move the CLOSE tab to the top? The slideIn is not scrollable so if it goes off the page you just wait until it goes away. This is more important for phones and other small mobile devices.

    I was thinking of replacing PopOver with slidein, but it has the option to never show the popover again. And Popover scrolls with the site.

    Larry

  • aecnu

    Greetings Larry,

    Thank you for your detailed input which is certainly appreciated as always and you mentioned Twenty Ten, what version of WordPress are you running?

    Twenty Ten had inherent bugs form the beginning and that is common knowledge but of course that does not explain Scholar.

    Yet using Scholar on my production server http://studio.aecnuwpmu.us/ there is no issue with it at all - it works flawlessly. I tested on top and on bottom.

    Did you go through standard trouble shooting protocol by any chance?

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven/Twelve theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • tishimself

    Hi, I suppose I should have said it now appears all sites including Scholar but not on the home page. Maybe was always working this way.

    This and the display issues mentioned limit my ability to use this plugin.

    I did try turning off some plugins, but did not complete the test because it readily fills the screen pushing the close off the bottom on my mobile device theme and w/o any way for the user to close it seems impolite.

    When I can keep the txt short, limit the display to once or twice(which I can't seem to do) and if it displayed on the home page, then I would have a use. The Pop Over plugin does not work at all on my mobile theme at all.

    Larry

  • aecnu

    Greetings Larry,

    Thank you for the additional input and indeed I had shown that it worked fine on the home page of Scholar and though I have changed the theme at the moment in another demonstration on that very site, I am happy to flip it back.

    I did try turning off some plugins, but did not complete the test because it readily fills the screen pushing the close off the bottom on my mobile device theme and w/o any way for the user to close it seems impolite.

    The way you described testing and to get to the bottom of this appears to be the opposite of the procedure that should have been followed.

    One would want to disable all non applicable items not relative to the item to be tested and see if that cures the problem - and if so then re-enabling them one at a time until the culprit is found if there is one - in addition this also reveals three way conflict issues which though rare indeed happen.

    Depending on the amount of plugins is a direct reflection of the time it takes to debug the installation.

    The fact that you mentioned that the Slide In still does not show on the home page is a direct reflection that the issue/conflict has not been resolved.

    Please advise.

    Cheers, Joe

  • tishimself

    Hi,

    The URL is 50mpg.org

    I upgraded to 1.1.1.

    I activated twenty ten, closed down plugins but the slider never appeared on my phone. Slider is set to "Hide all messages for the visitor." which I think means to not display the slider again if the user has closed it. I open on each page and closing makes no difference, I reload the page and slider is there again. I go to another page and back and it is there again. The slide never appears on my home page.

    If you pull it up on an iphone you will see the mobile theme.''

    Larry

  • aecnu

    Greetings Larry,

    Visiting your site today with a browser on a PC the Pop Up! is not appearing on your home page and it does on the sub pages/posts.

    Slider is set to "Hide all messages for the visitor."

    I believe this means that anyone not logged in will not see the slider at all.

    Can you get the slider to display on the home page in any event, under any circumstances??

    Have you enabled the troubleshooting add on Test Head Footer by any chance? i.e. admin dashboard --> Pop Overs --> Add Ons --> Test Head Footer --> Activate.

    Please advise.

    Cheers, Joe

  • tishimself

    Hi,

    I set it to Keep showing message to the visitor.
    I was hoping I could find a way to display the SlideIn once. But it comes up on each page and again when the page is refreshed.

    No the slide in has never appeared on the home page.

    There is no Pop Overs selection on the Network Admin Dashboard (or the site dashboard).

    I'm a bit confused, we are talking about the Slide In plugin not the Pop Over plugin.

    Larry

  • aecnu

    Greetings Larry,

    My apology for the confusion which it is obvious I caused somehow going pop up on us and even mixing in a little slide in as well in my last post ... lol That is what i get for multi tasking too many tickets ... lol

    In any event, back on the Slide In track and not knowing why it is not appearing on your home page and on my scholar plain jane install it works just fine:
    http://studio.aecnuwpmu.us/

    And you are indeed correct that Keep showing messages to the visitor is is the setting we want to be testing with.

    Could you please update to the latest version 1.1.2 which the change log indicates related items:

    - Fix for timed messages reappearing on scroll.
    - Added home page and custom post types to conditions list.
    - Introducing custom taxonomies for related posts.

    Please advise if this fixes the issue with the home page slide in - in which I indeed tested again today and still found that the home page does not show but pages it shows fine.

    Please advise on how it goes after the update.

    Cheers, Joe

  • tishimself

    Hi,

    I've been testing this on two sites different themes, desktop and iPhone.
    Actually they both use the same iPhone theme.

    1). http://psychotherapy-network.com/
    I tried flipping between the Scholar child and Parent and the slider appears on all but the Home page.

    But it also appears on the mobile them, just huge and returns everytime I touch the screen to scroll. The close button is off the screen. I could shrink it down in size but the fact that it comes back with a touch of the screen makes it unusable.

    There is also no control over repeated displays. It can't be made to display once and go away forever when closed. Much too disruptive.

    2). http://50mpg.org/
    When I use the Twenty Ten theme it displays on all pages and posts.

    When I use my responsive theme it displays only on posts and not on pages.

    When I go to my iPhone displays only on posts not on pages. Well actually it only displays on the Posts when I to them via the menu. If I go to them off the home page then no. Better than nothing.

    BTW, PopOver does not work at all on my iPhone mobile theme.

    I think you guys would benefit by supporting mobile devices. Pick a way of doing this and support it. If I was to pick, then WPtouch compatibility would be the choice. (Responsive themes are just not mobile themes.) Then you could develop mobile themes which is the direction things are going.

    Larry

  • aecnu

    Greetings Larry,

    Thank you for the additional input and feedback which I will certainly bring this item to the lead developers attention but first we should sum up what is still happening after applying his latest release version 1.1.2

    Our system indicates you are using version 1.1

    Please update and let me know what issues remain if any.

    Look forward to hearing form you in any event.

    Cheers, Joe

  • tishimself

    Hi,

    I just upgraded from 1.1.2 to 1.1.3 on both sites, but it is now active only on my test site.

    I did not notice any changes after this upgrade.

    One thing to add is the Mobile version works on post extracts, but then when I select "Read This Article", it does not appear. Read this article is when the PPV form gets added to the content. It seems to be fine with the desktop theme.

    Larry

  • aecnu

    Greetings Larry,

    Thank you for the additional input which is absolutely appreciated.

    After reviewing your post again:

    https://premium.wpmudev.org/forums/topic/problems-with-slide-in#post-409014

    I thought it was in our mutual benefit to let the lead developer @Vladislav know about this post and as you see I have gone ahead and sent a flag over to him so he can review what we have going on here and possibly add his comments/opinion as well.

    Hopefully he will find the time to make it in here sooner then later and I am going to move this to the feedback area as well thinking it is the best applicable category thereof.

    Have a GREAT week ahead!

    Cheers, Joe

  • Vladislav

    Hello,

    Thank you for such thorough testing and issue report. Before we go into mobile issues, can we please first try debug the issue where the slide-in doesn't appear on your home page, because those are most likely separate. What are the condition settings for your slide-in? Also, what is the trigger used to display it (percentage of the page passed, elapsed time or scrolling pass an element)?

    If your theme triggers the wp_footer hook (which it hopefully does), one thing you may want to try right away is to configure the plugin to use this hook instead of the default. To do so, navigate to the plugin Global Settings and, in the Advanced section, enter "wp_footer" in the text box labeled "Custom injection hook" (you can easily revert back to default by just clearing all content from this box and re-saving the settings).

  • tishimself

    Hi,

    I don't understand your comment.

    >absolutely you can limit the displays of the slide in
    If there is a way, what is it?

    > I want to then you have a choice of a few options and one is to not show it again as well

    Or are you saying you what the this is not yet available and you want it too?

    IMHO, it not a want:

    If the presentation of the slide-in can't be limited, then it is offensive to users.

    Larry

  • aecnu

    Greetings Larry,

    Thank you for the clarification and questions.

    >absolutely you can limit the displays of the slide in
    -- If there is a way, what is it?

    Logged into the admin dashboard go to --> Slide In --> Global Settings --> Closing the message --> When a visitor closes a slide-in message, I want to then applicable option.

    > I want to then you have a choice of a few options and one is to not show it again as well

    -- Or are you saying you what the this is not yet available and you want it too?

    These options are available as described above.

    Let me know how it goes.

    Cheers, Joe