Problems with Upfront and Spirit Template

Ok, so I purchased this product because it looked like it was going to make a whole lot simpler for me. But so far I am a bit frustrated. I installed and activated the Spirt theme using the WPMU DEV admin plugin. When I click on "Upfront" at the top of the page. it loads the page as it should so that I can edit it. However, when I go to edit the "Spirit" image, it does not give me the option to select an image, nor can it ever get out of the image dialog box and everything else becomes disabled. Furthermore, when I add a page, I can edit the page. But the page does not populate like it is supposed to. When I click "View page," I receive a 404 not found error.

  • Michael Bissett

    Hey @kenny_d, hope you're doing well this weekend (the issues you've encountered so far aside)! :slight_smile:

    I'm seeing that doing those things worked just fine on my test site, I was able to choose a different image to replace the "Spirit" image, and I was able to create a new page (using the About Page template), save it & visit it without issue.

    Just as a basic test, could you try disabling the plugins on your site, and refreshing the permalink structure (this can be done by going to Settings -> Permalinks, and simply saving the settings there), and seeing if you're able to do those things then?

    If not, I noticed that the Support Access you granted here is giving me a "invalid access token" error, could you please revoke & re-enable it? :slight_smile:

    Thanks!

    Kind Regards,
    Michael

  • kenny_d

    Ok, so while I have been waiting for this "24/7 Support", I decided to check the log file for any errors since I still cannot do anything with images. Interestingly enough, I have found the following error listed in the log file:

    File does not exist: /var/www/d2solutionsgroup/upfront-dependencies, referer: http://d2solutionsgroup.com/

    Now I am no rocket scientist here, but it appears that the dependencies file that is supposed to be located under the d2solutionsgroup folder, does not exist. -OR- the configuration files are incorrectly referencing the file path.

    So, now I would love to get some of that "24/7 Support" that you all like to brag about on your main page. Thanks. :disappointed:

  • Tyler Postle

    Hey there Kenny,

    Glad you're having a good weekend!

    Working alongside David here, I can see he has asked for your login details privately through email as we still can't login through the support access. I will get those from him once you send them in if that's okay :slight_smile:

    Then I can take a closer look here.

    Just to note too, our support works on a feed system, so when an answer is replied to by a member then it pops the thread back into our que and we work from oldest to newest, to ensure everyone gets the same level of support and no tickets get dropped :slight_smile: sometimes are response times will vary depending on the amount of tickets - we of course always try to work through them as fast as possible while still providing quality solutions.

    Hope you enjoy the rest of your weekend and I will be speaking with you again soon once I get those credentials!

    Cheers,
    Tyler

  • kenny_d

    Tyler,

    I sent the information over to David in response to his email. And thank you for the response. And I can certainly understand and appreciate the ticket system your team has developed. Maybe you can add an expected response timer so that way we know when to expect a response?

    The reason that my response seemed a bit snarky is that the first response came about 1 hour after I submitted, but the follow up response took almost 4.5 hours. And not knowing any different (since I am a new user with WPMU DEV), it felt like the 1st response was supposed to fix all of the problems - which it didn't, unfortunately.

    Regardless, I do look forward to figuring out why this is acting a bit strange.

  • Tyler Postle

    Hey Ken,

    Thanks for your reply and sending in the login credentials.

    An expected response timer is a really good idea. I usually like seeing those when sites have them. We might have to look into something like that :slight_smile:

    So, it looks like the cause here may have been something you added through the Upfront editor. When I visit your site and enter the editor in dev mode it loads everything fine, you can try this out yourself:

    d2solutionsgroup.com/?dev=true&editmode=true

    Do you remember what changes you made before the issue started happening and also do you see any other errors in your error log?

    Talk to you soon!

    Cheers,
    Tyler

  • kenny_d

    Well, it still is not working correctly. I still cannot add images. In an attempt to start over from zero, I have deleted this WP install, and did a completely clean install. Install went as follows:
    - Installed WordPress
    - Deleted all existing themes, except default theme (2015)
    - Deleted all standard plugins
    - Installed WPMU DEV plugin
    - Then clicked on the 'Spirit' theme and installed it.
    - First action is to replace the 'Spirit' image. Clicked on the spot where it says "Click here to change image". Theme locks up and throws the error previously mentioned:
    File does not exist: /var/www/d2solutionsgroup/upfront-dependencies, referer: http://d2solutionsgroup.com/

  • Tyler Postle

    Hey Kenny,

    Hope your day is going well!

    Thanks for your replies here. I'm going to flag this for one of our Upfront theme developers to take a closer look at, this is first case I've seen with that error. It could be a server side issue.

    Would we be able to get a copy of your database by any chance? Hope that's not asking too much. It would help us troubleshoot the issue. You can send that in to contact [at] wpmudev.org and make the subject line "Attn: Tyler Postle" OR upload it to one of your directories then we can just use your FTP to grab it :slight_smile:

    Once they have looked further into this then they will post back here. Keep in mind, they of course have a lot of other responsibilities so their responses may be a bit slower.

    Talk to you soon!

    Cheers,
    Tyler

  • Jack Kitterhing

    Hi there @kenny_d,

    Hope you're well today, we've been looking into this today for you, the 404 for the missing file, is a little mis-leading, as the actual file itself, is virtual and isn't a directory within the theme, we believe this is related to specific PHP configurations, one of the Upfront developers also has the same issue on his local host. He's currently working on a fix for this and we hope to have it out ASAP.

    I'l keep you posted on when the fix becomes available, sorry about this, in the mean time, if you need to start working on the site, you could delete the elements by clicking the "x" and then dragging across new elements.

    Thank you!

    Kind Regards
    Jack.

    • Jack Kitterhing

      Hi again @kenny_d,

      Just a further update, looks like anything related to the media does indeed stop loading and freeze up (due to the dependencies issue).

      One work around (though not suitable if you plan to do a lot of work). Load your site like this

      "domain.com/?dev=true"

      Click the Upfront link, you'll be able to use Upfront as intended, make changes, swap images etc, you should see a image I swapped if you visit domain.com/?dev=true

      By adding that to the end of the URL, it actually loads a special layout, rather than the normal layout, and is all contained in that layout. This means when we get the fix out, any changes in dev=true, are not transferable to domain.com.

      But if you need to show a client any work etc, you could place a 302 redirect (temporary), in your .htaccess file so that any requests to domain.com are automatically sent to domain.com/?dev=true

      Thanks.

      Kind Regards
      Jack.

  • Jack Kitterhing

    Hi there @kenny_d,

    Hope you're well today, after some further testing on the site we could replicate the issue on, it appears the issue has to do with apache and specifically the lack of a virtualhost.

    Adding.

    <Directory "/var/www/html">
       AllowOverride All
    </Directory>

    Resolved it on our own install, could you try that on yours and check if it resolves the issue on yours? If not, please advise and we'd be happy to take another look, also if it does work, we can look into some more specific rules rather than AllowOverride All.

    Thanks!

    Kind Regards
    Jack.

  • ericstownsend

    I know this thread is over a year old, but I had a similar problem, i.e. getting 404 for loading the combined/minified css/js files at the URL mysite.com/upfront-dependencies/...

    In my case, the problem was a mis-configured Nginx site config. The key directive that I had not set up correctly was:

    location / {
            try_files $uri $uri/ /index.php?q=$request_uri;
    }

    Just thought I'd drop this in here in case anyone else like me stumbled upon this thread! :slight_smile: