Product Page not showing - Error 404 even when permalinks flushed.

Hi, I have just purchased Marketpress.
I am running a current Wordpress install with WPML enabled - all working fine.
I have also downloaded and installed WPML Marketpress plugin (as instructed by WPML).
I have uploaded 3 products to Marketpress, and tested them on a new page I created using shortcodes - all 3 products all appear.
However when I select the title (and it should go to the product page) I am taken to an Error 404 page. When I refresh and try to 'purchase' an item (nothing happens), but clicking the shopping cart also gives me an Error 404.
I have also tried to view store/products and repeatedly get an Error 404 for each of the MarketPress Urls.
So.. I have refreshed the permalinks many times - but to no avail.
****.com/store/ takes me to an Index of Store with directory and cgi-bin.
- - -
I have tried switching themes. Makes no difference.
I have tried turning off all plugins. Makes no difference.
I have turned on WP Debug and received these notices:

Notice: Trying to get property of non-object in ../plugins/wpml-marketpress/wpml-marketpress.php on line 519

Notice: Trying to get property of non-object in ../plugins/wpml-marketpress/wpml-marketpress.php on line 520

these are in the WPML plugin - so perhaps I should pose my question there? The code on those lines are:
$post_id = $post->ID;
$post_type = get_post_type($post->ID);

Any help is much appreciated. Otherwise I'll just cut my losses and try another ecommerce solution.