Product Variation Losing name and become numbers

Creating product variations the first round works, but as soon as you try to on another item it loses the values you entered and gives them a number. Any ideal on what is causing this?

In theory I would think that it would populate what you have set in the attributes but nope you have to add each option every time on every product.

  • Milan

    Hello Kevin,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    Creating product variations the first round works, but as soon as you try to on another item it loses the values you entered and gives them a number. Any ideal on what is causing this?

    I was able to replicate this behaviour on my end one time after doing lot of failed attempt, so it is there as bug somehow, I am notifying our developer about this and hopefully they will attempt this issue real soon, Meantime you can just change back those number to variation name again, I know its time waste but till bug gets identified and fixed, this trick is our saviour. :slight_smile:

    In theory I would think that it would populate what you have set in the attributes but nope you have to add each option every time on every product.

    Yes this is how it is working. I think our developer would have thought that every products comes with new variation attributes so its not good idea of fetching and filling new product's variation attribute input with previously added attributes. But I also think, it has some drawbacks too, Sometime it may cause time waste if user is about to add same attribute for his/her most new products. So something like setting up variations default value in store settings and then importing it if user wants will be good feature. What do you think ?

    Looking forward to hearing back. :slight_smile:
    Kind Regards,
    Milan

  • Milan

    Hello Kevin,

    Sorry to hear that solution will not work in your case, ( I thought you would have very less attributes. I should have asked you at first! Sorry for that. ) But anyway I noticed closely what is the issue, and created detailed bug report for our developer, so that they can understand what we are facing on our instillations and start their work for fixing this as fast as possible.

    Meantime May I ask you to cooperate and wait till bug gets fixed ? I will try to ask some temporary fix for this to our developer, if I find one I will surely get back to you on this one, or developer will reply you.

    And if you have something else to share or ask, I am here to help. :slight_smile:

    Best Regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.