Products not showing up on store front

I have been looking through the forums and cannot quiet find an answer.

I have setup the store (using our owne theme) - however when you go to the store front no products are displayed - this is the same for when you click the products link.

The products do however show when you click a catgeory. The styling is far from what we need at the moment, but without seeing any products (despite there being quite a few in the product list) i will struggle to try styling it.

I have made sure that the grid view is displayed - I have watched all the videos on the usage, but still no joy.

I apologise if I am missing something simple - we are moving from woocommerce to marketpress as our main user got confused by the complicated setting up of products - market press seemed much more intuitive. I just hope I can get it looking ok - thats why I need to start by seeing a few products :slight_smile:

I hope someone can help.

Kindest Regards

Rick.

  • Vaughan

    Hi @ricky_farr,

    Firstly, let's try & eliminate a theme issue. Can you quickly switch to the default 2012 theme & then visit the store page

    /store/products/

    Let me know if you see any products.

    Does your theme use standard wordpress functions such as the_content() etc?

    I logged into your dashboard using the support access which you have granted.

    I actually see 2 Products menu items & 1 called product lists. I don't see any plugins installed though that create these, does your theme register these as custom post types? this could potentially be the cause.

    I added a new page called products & used the shortcode to list products, this seems to work in your theme, but not when it's added with store being it's parent.

    http://www.chalkshirealpacas.com/products/

    I'm thinking this has something to do with the custom post types above.

    Hope this help

  • ricky_farr

    Thank you for the very quick reply and useful help.

    Our theme does come with a product specific page - of which I have messaged the theme developer to see how to remove this theme component in case there is a clash / conflict with MarketPress.

    I completed as asked .... activated the default 2012 theme and then went to the store front - no products show. However the product page you created does show items.

    I will await a reply from the theme developer before requesting any further assistance.

    Many thanks for your help.

    Kindest Regards

    Rick.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.