Profile Dropdown Menu Not Working After Update

Hi there,

I'm having issues after the update to membership Pro 2. It seems that my Profile Menu Dropdown (default Admin bar - Dashboard, My Sites, Etc) is not working anymore. When I disable the plugin, its working fine.

I'm on a multisite with buddypress and membership pro 2 only on main site activated (so the issue is on the main site).
Using on the main website is the Boss theme from buddyboss (also addressed the issue there) http://www.buddyboss.com/support-forums/topic/profile-dropdown/#post-42184

I already gave permission for support on my WPMU dev dashboard, just in case any of you need to have a look.

Any other advice is highly appreciated.
Cheers,

Ronald

  • Vinod Dalvi
    • WP Unicorn

    Hi Ronald,

    I hope you are well today and thank you for your question.

    I could confirm on your site by creating a test user account the the admin bar menus were not displaying for non admin users.

    I logged in to your site using support staff access and found you had selected the "Hide admin toolbar" option in the Membership 2 Settings on the following path as shown in the attached screenshot which was causing this behavior.

    Admin Area -> Membership 2 -> Settings -> General

    I have just disabled this option on your site and could confirm the admin bar menus are displaying for non admin users.

    Could you please check it and let me know how it works for you?

    Best Regards,
    Vinod Dalvi

  • Dutchman
    • The Bug Hunter

    Hi Vinod,

    Thanks for the very fast service. I wasn't expecting that fast, so I was trying out some issues with the custom admin bar I have with Ultimate Branding plugin. That's why the hide admin bar was on (the ultimate branding was causing issues with my theme as well).

    Even without that, coming back to this issue - the dropdown profile menu - its still not working.
    I tried with various users.

    You can see it with your test user as well, can't you?
    I attached a screenshot of my admin user that is working and what it should look like for all users.
    Atm all users only have a logout button and nothing else (same as your test user?)

  • Vinod Dalvi
    • WP Unicorn

    Hi Ronald,

    I have tested it using test user account on your site and could confirm that the "My Sites" and "Dashboard" menus in the front end are only displayed for admin user.

    Non admin users can access the "My Sites" menu in the admin area and the Sites menu in the front end as shown in the attached screenshots.

    It seems the default theme functionality so you can ask your theme author more information about it.

    Thanks,
    Vinod Dalvi

  • Dutchman
    • The Bug Hunter

    Hi @Vinod Dalvi

    Thanks for the reply, but it seems that its working with a little detour as you just showed me.
    The thing is, it was available in the profile dropdown itself (when users have a site, it will popup under a submenu of that site).

    Anyways... thank for the help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.