Profile Visibility - Not Working

On my Profile visibility settings I have set Last Name to be visible to Only Me, but there it is - out in full view of everyone. I thought that Username was the default for Wordpress.

I actually don't want anyone seeing any of my members's First or Last Names. The only name that should be visible is Username.

How do I accomplish this please?

See screenshot showing setting of Visibility (Only me) but it is visible at the top of the page and also in the widget of Members.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Mary,
    Hope you are doing good today :slight_smile:

    It appears that you are setting visibility on primary field of BuddyPress. If yes then its a required special field that BP use everywhere.

    In this case I would suggest you to make that primary field nickname and add two other fields (first and last) from Admin -> Users -> Profile Fields and set their visibility.

    You can see if this field is a primary or not in Admin -> Users -> Profile fields. There will be label (primary) to that field and also you can't delete this field as well (see screenshot).

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.