Progress Meter reporting incorrect (CoursePress Pro)

Hi there. I launched a Support Ticket in August 2015 (7 mths ago) where WPMU acknowledged an error which was logged for fixing.
This issue seems related, but may not be.

When a student is looking at their own units: the progress circle reports as 100%, even when a student has unanswered questions. Even when they have answered no questions in a unit, it still reports 100% complete.

in Unit:

In Workbook:

I have granted Support Access. Can you please review this, ta.

  • Rupok
    • Support Ninja

    Hi Jeremy

    Hope you had a wonderful day.

    Thanks for granting Support Access. I just logged in and tried to troubleshoot. Can you check the "User needs to answer all mandatory assessments and view all pages in order to access the next unit" option for each unit in your courses? Because without this, students can just see the questions without answering, and then go to next unit. And when they reach the last unit, it shows 100% . Please check the attached screenshot for reference.

    Can you please let us know if this solves your issue? If not, we will be glad to investigate further.

    Have a nice day. Cheers!

  • Jeremy
    • WPMU DEV Initiate

    ah ok.

    I have set up a duplicate course to play with "TEST ONLY - How to Get Lost in the Bush (copy BLAC)".

    However when doing this suggestion (that checkbox "User needs to answer all mandatory assessments and view all pages in order to access the next unit"), it works but doesn't:

    1. displays: "2 of 2 mandatory elements completed" - this is good
    2. progress icon shows 66% (is this because it is yet to be marked?)

    But the big problem is the student can't progress to the next unit, presumably because the first answer needs marking.

    The checkbox "User also needs to pass all mandatory assessments" remains unticked, so why cant the student progress?
    Can you let me know your thoughts as to the best approach to make it work.

    As it is this would be entirely unfit for purpose, as with 10 units x 10 questions = 100 questions, and maybe 20% requiring marking, it would take weeks/months for someone to complete a course because of waiting for marking to be done, then waiting for the student to answer the next few questions, and it would be hugely frustrating for students and trainers. So I'm just not sure what the best approach would be here to get this working.

  • Kasia Swiderska
    • Support nomad

    Hello Jeremy,

    I've checked that bug report from your previous thread and PHP notice should be fixed. There were also developer comments about the percentage progress:

    Percentage is calculated on the following: pages viewed and mandatory questions completed. A mandatory question is only completed if it is a) Not gradable, b) Gradable AND passed.

    In your test there is one open question - could you try to leave "Answer is mandatory" but untick "Assessable", this should turn off the need of you marking this answer so student can continue with test.

    kind regards,
    Kasia

  • Jeremy
    • WPMU DEV Initiate

    This sounds like it is impracticable (we need answers to be marked).

    It seems like WPMU have added answer field questions in response to demand for it, whereas they don't really work in a reasonable manner (you can have them if you won't want to have them marked).

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.