Prompted to update my theme to an earlier version

My site keeps asking me to update spirit and upfront - how ever when I look at the versions it would like me to update to an earlier one?

Spirit
You have version 1.1.2 installed. Update to 0.1.7.
Upfront
You have version 1.2.2 installed. Update to 0.4.1.5.

This does not sound right?