Prosite sign-up page not working: too many redirects

It was working fine, till I updated a few of your plugins, but now my Prosite Sign-up page is not working. I did a search and performed some of the suggestions about forcing https on domain mapping, but that killed my entire site, not just my sign up page. Can someone help ASAP?

  • bayfish
    • Flash Drive

    It's definitely an SSL problem. I turned off the Force SSL on the Stripe gateway page in Prosites and the sign-up page showed. While the Stripe SSL was turned off, I tried turning ON the force front pages to https in domain mapping and the whole site stopped working.

    OK, the SSL in general works. I also have WooCommerce set-up and that SSL connection is working fine.

    So it seems there is a problem with the Stripe gateway in Prosites

  • Rupok
    • Support Ninja

    Hi bayfish,

    So sorry for the inconvenience. This is really weird and should not happen. I've just checked Stripe Payment gateway in my SSL test multisite and Sign Up page is working fine in both cases when I set "Force SSL" or "No SSL". I've tested with both Sandbox Mode and Live Mode. So I think, this is your site specific issue.

    As you said "my Prosite Sign-up page is not working", can you please tell us how that page is not working? I mean, does that page not load at all or it loads but payment options are not shown? Or something else?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access and let us know if we are okay to test your Domain Mapping SSL and Pro Sites Stripe gateway settings. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • bayfish
    • Flash Drive

    Now that I think about it, I had a client sign-up using the ProSites sign-up page, but he couldn't do the WooCommerce order because I didn't have the force SSL checked. I did some testing and found that when I uncheck Force SSL on WooCommerce, the Prosite Sign-up page works, but the WooCommerce Stripe Checkout does not work.

    So it seems there is a conflict between the ProSites Stripe force SSL and the WooCommerce Force SSL.

    I tested some more and found that when I checked the WC Force SSL and left the "Force HTTP when leaving the checkout" it all seems to work.

    But the question is this the correct way of getting this done?

  • Nithin
    • Support Wizard

    Hi bayfish,

    Hope you are doing good today. :slight_smile:

    This seems to be a common issue with WooCommerce, as I was able to find similar threads:
    http://www.anterik.com/fixed-infinite-redirect-switching-woocommerce-site-ssl/

    Enabling these option would direct users from HTTPS, to HTTP so there is a chance for these redirect errors to occur, I suppose this might be the workaround, however would recommend you to get in touch with WooCommerce in order to have a clear picture whether this is the proper way, or not, and how that option is meant to be used.
    https://wordpress.org/support/plugin/woocommerce

    I hope this helps. Please let us know if you still need any further assistance. Have an nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.