Prosites Dashboard Widget and Video Shortcut issues

Hi,
I\m currently staging a pro-site powered multi site and have two issues I'm hoping you can help me resolve.
1. This is directly related to the Ultimate Brander (at least I believe). When I customize the Dashboard Widgets the video shortcode does not seem to work on any site. I put in the ID and everything looks good, however when viewed in the dashboard both Youtube and Vimeo videos fail to load and give errors indicating it is a deadlink (though it is not) . It seems as if the video ID is being changed.
2. UPFRONT Builder: When testing a fake user site I noted that when I goto UPFRONT to edit a page that the ... menu which provides the 'Close Upfront' option does not open. Two notes on that...I tested the fake site in IE while conducting the admin work in Firefox. While I opened upfront to edit a page as an admin in Firefox it does open. Is this a known issue? I don't recall this happening until I started using Ultimate Branding, but I'm not positive that it worked prior.
3. Finally a general question if you have a link to documentation I can look over , if not no big deal...I can look around. I'm new to multisite and pro-sites as well. Is there shortcode or other coding available that I can utilize to display user specific information to the individual logged in at the time? Actually it would be better stated is there a good list of those codes as I recognize some (specific to plugins) . An example would be using a code like [my-account] to show the logged in individuals woocommerce account info. I realize various plugins and themes utilize different codes. Is there a list specific to multi-site?
Thanks for your excellent support ahead of time. I've been using wordpress for years, and just recently stumbled on your paid services (though I'm sure I've read many of your articles on searches). Your free trial won over a long term paying customer. I'm very pleased with all y'all offer.
Shane

  • James Morris

    Hello Shane,##1

    I hope you are well today. I'll be happy to help you with the issues you're experiencing.

    In order to help you better, would you please grant me access to your site? This will help me better visualize what you're describing and perform some preliminary debugging.

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • James Morris

    Hello Shane!

    1. This is directly related to the Ultimate Brander (at least I believe). When I customize the Dashboard Widgets the video shortcode does not seem to work on any site. I put in the ID and everything looks good, however when viewed in the dashboard both Youtube and Vimeo videos fail to load and give errors indicating it is a deadlink (though it is not) . It seems as if the video ID is being changed.

    Actually, this was related to depreciated video embed shortcodes. The shortcodes you were using have been replaced with other options such as oEmbed (raw link) and [embed] shortcode tag. In your situation though, the iframe option is by far the most flexible. I've updated the code on these 2 dashboard widgets with the correct iframe code so you can see how this will work.

    2. UPFRONT Builder...

    I'm seeing that Upfront Builder is not currently installed on your site. So, I was not able to test that. However, I did create a test site and was able to use Upfront Editor on the Gillie theme without issue. If you would still like assistance with Upfront Builder, would you please re-install it and send me a screenshot of the problem you are seeing?

    3. Finally a general question if you have a link to documentation I can look over , if not no big deal...I can look around.

    On each plugin's page, you will see a section for Usage. This provides a good general overview of how to setup the plugin and start using it on your site. For example, the Usage Docs for Pro Sites is at https://premium.wpmudev.org/project/pro-sites/#product-usage

    Also, we are expanding our Documentation to be more in-depth. You can can find these more detailed Docs at the following link: https://premium.wpmudev.org/manuals/

    We've also published a large library of Video Tutorials: https://premium.wpmudev.org/projects/category/videos/

    And don't forget we have our Academy where you can learn from an instructor on how to get the most out of WordPress Multisite: https://premium.wpmudev.org/academy/

    I'm new to multisite and pro-sites as well. Is there shortcode or other coding available that I can utilize to display user specific information to the individual logged in at the time? Actually it would be better stated is there a good list of those codes as I recognize some (specific to plugins) . An example would be using a code like [my-account] to show the logged in individuals woocommerce account info. I realize various plugins and themes utilize different codes. Is there a list specific to multi-site?

    As you already mentioned, it will depend on the plugins involved. For Pro Sites, you may find the following thread useful for displaying different account information on your site: https://premium.wpmudev.org/forums/topic/are-there-shortcodes-for-pro-site

    There are a number of plugins that allow you to do custom user profile pages, but if you want the maximum amount of flexibility that you can code in support for other plugins, I strongly recommend spending some time on the WordPress Codex, particularly this page: https://codex.wordpress.org/wp_get_current_user

    That native function will allow you to retrieve and display every value that has been associated with a user and stored in the user_meta table.

    Here's a simple example of a template you could extend:

    <?php
        $current_user = wp_get_current_user();
        /**
         * @example Safe usage: $current_user = wp_get_current_user();
         * if ( !($current_user instanceof WP_User) )
         *     return;
         */
        echo 'Username: ' . $current_user->user_login . '<br />';
        echo 'User email: ' . $current_user->user_email . '<br />';
        echo 'User first name: ' . $current_user->user_firstname . '<br />';
        echo 'User last name: ' . $current_user->user_lastname . '<br />';
        echo 'User display name: ' . $current_user->display_name . '<br />';
        echo 'User ID: ' . $current_user->ID . '<br />';
    ?>

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • Shane

    James,
    Thank you for the detailed reply! I used the embed shortcode option on the editor for the video.
    1. I guess I should have just done as I typically would have and used the embed code instead. Works as it should.
    2. I have tracked it down to an IE issues. I'll hold off on following up with that as I'm just running test on a sample site. When I go to actually begin building the real site if it is still present I will open another ticket.
    3. Thank you for the links and resources.

    As always I'm extremely pleased with the support system here. Absolutely the best and most thorough I've encountered online. Definitely worth the membership cost!
    Have a great week.
    Shane

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.