Protected Content

Good-evening!

I'm having a bit of a problem. Either because I do not understand exactly how this work or something is out of whack with my settings.

I have created Free Access Level and even added Free Subscription to the site. The idea been to allow users access to the frontpage and other pages for them to understand what the site is all about.

But from what I can see from both from desktop and mobile devices, when users come to the site, they are confronted with a "Protected Content" page instead of the site's Home Page.

We have set "User accounts may be registered." in the options and none of these pages have protected content enabled.

Please what am I doing wrong? Is there anybody who take a look at our configuration?

Thank You!

  • T-chan

    Good-morning, Mr. AECNU!

    I actually did! In fact when this started, it was set to "Visitor". Then I created a "FREE" access level and subscription but nothing changed.

    I have attached the screen-shots.

    It will be a disaster if I have to remove the plugin. Everything I have done is tied up with it and have also finish the translations and the pages have linked together.

    Please help! I can create an account for you if you want to take a look at the site itself.

    Thank You!

  • aecnu

    Greetings KnightHawkXIV,

    Thank you for your additional input which frankly says a lot.

    First you want to set your stranger settings back to visitors because otherwise nobody can see your site unless they subscribe which they cannot because it is all blocked.

    Free for user registration is fine.

    We are using Janrain too for Registration on the site.

    I do not know what that is but the Membership plugin MUST have total control of the sites/network and registration.

    First get your front end and registration page working then we can go after the other details.

    Please advise.

    Cheers, Joe

  • T-chan

    Good-morning, Mr Joe!

    I have set back the Stranger Setting back to "Visitor" and left the User Registration to "Free" as you asked us to do.

    But the situation remain as it was.

    I do not think that Janrain has anything to do with this since it is just social login tool.

    Please (if you have the time) can you take a look at the site or is there anything else I can do to remedy this situation?

    Thank You so much!

    Respectfully,

    Takeshi

  • T-chan

    More on this Mr Joe and this is what I have done now. I disabled Content Protection. Not that I really need that since Pro Site handles that well too. All I needed was a system that can ensure recurring payment and membership subscription with or without content protection.

    How this will affect Membership Plugin function/performance, I don't know. But it will be great if you can throw some light on this. I wish that one can just place a short-code on a page to protect it instead of the universal configuration it presently has; (must admit I'm even sure if what I'm saying make sense. Maybe this is already present).

    Can users use the Registration, Subscription and Welcome pages without Protection Content enable? As far as I can see now, the site is visible on desktops and mobiles just the way it ought to.

    Again, thank you!

  • aecnu

    Greetings KnightHawkXIV,

    Thank you for your additional input which is absolutely appreciated and helping to give a vision of what is going on there.

    Regarding Janrain, I have no idea if it is interfering or not but it is just one piece of seemingly unrelated code that can ruin your whole day and it is as simple as deactivating it to see if it indeed conflicts.

    The toughest part about your issue is that I cannot replicate it.

    Please consider sending me wp admin login details so that I can take a peek at what you got going on there to aecnu (at) incsub.com

    I am sure the answer is there.

    Please advise.

    Cheers, Joe

  • T-chan

    Good-morning, Uncle Joe!!

    We have upgraded your profile with the advices privileges. We also disabled our social login but you can enable via Super Admin plugins to check whether it has any impact on Membership though that is highly unlikely.

    We also intend to use Janrain Capture (presently not enabled) and that is the one that takes over site's native registration. But that is if we sort this issue out.

    However if you still think that this is a bad idea, we will defer to your professional opinion.

    Wishing you a very beautiful day!

    Thank You!

  • aecnu

    Greetings KnightHawkXIV,

    Sorry for the delay here and I had tried to get in there and check out what was going on. We have been slammed with new members here on WPMU DEV and the work load enormous which is an understatement.

    However, just tonight your ticket appeared back on my screen.

    You are indeed correct that it the negative and positive rules work funny and though I do not know why I have found that they have worked the opposite on different sites.

    The only way to be sure how sites and configurations will act is testing and more testing and keeping in mind what works and/or how it works for your specific installation.

    Please advise where we are now with your installation and hopefully we can resolve the last of the issues if any that you are having.

    Looking forward to hearing form you in any event.

    Cheers, Joe

  • T-chan

    Good-morning, Mr Joe!

    This response is late but I have been trying to understand much on how this work. Anyway, I removed all the rules for Access Levels and used implemented that only for FREE/Visitor.

    Taking too much figuring out what and what-not on this. Would have been easier in IMHO to disable the General Protected and use only short-codes when you need a Page to be protected.

    I know short-codes are already existing on Membership but it is kinda tough taming this beast.

    BTW, I tried to implement Multi-DB but failed woefully. All worked out fine but get the "Houston stuff ......" even though it offered me other options.
    Will need your professional help on this.

    How much will this cost for your company (saw your website) to implement this safely for us, Mr Joe?

    Thank you!

  • aecnu

    Greetings KnightHawkXIV,

    Thank you for the update and the confidence you expressed in your last post, it is noted and appreciated.

    Regarding your protected content, my favorite way of doing this is using URL Groups to control access to categories by URL's

    Regarding the Multi DB installation, how many DB's are you wanting to institute?

    Are you anticipating a bunch of sub sites or?

    Please advise.

    Cheers, Joe

  • T-chan

    Good-morning, Mr. AECNU!

    The client requested for 16DBs and I think that is enough given where they are. Another thing I will appreciate if you can give me any hint is why are we unable to create new sites via other sites on the network; for an example: http://somesite.com/blogs/create/.

    When we add Site Domain, Title, Privacy, Tagline,Site Category and Desc., click on "Create Site", nothing happen. The page will re-load without creating the site. We can only do that via Network Admin. I will remove Multi-Domain and Domain Mapping and re-install them again to see what comes up. However if you feel there is something else to do before we proceed with the removal, please let us know.

    BTW, don't you think that this:

    "If you’re not going to use a great domain, leave it for a new user. Now have at it!"

    ought to be:

    "If you’re not going to use a great domain, leave it for a new user. Now have a go at it!"?

    Eagerly waiting for your reply.

    Thank You!

  • aecnu

    Greetings KnightHawkXIV,

    Sorry to see that you continue to have issues.

    Regarding the site creation issue, please try creating a site with Multi-Domain and Domain Mapping removed as you have proposed you are going to remove and reinstall but before the re-installation testing the basic working of the site.

    Regarding the following statements:

    Correct in American English:
    "If you’re not going to use a great domain, leave it for a new user. Now have at it!"

    Correct in British English:
    "If you’re not going to use a great domain, leave it for a new user. Now have a go at it!"?

    To me the last one sounds funny, but I am an American so it would ... lol

    Please advise as to how you make out in any event.

    We can work over the Multi DB situation once these other things are worked out, we do not want issues to be spreading or carried over into the Multi DB of course.

    Cheers, Joe

  • PC

    Hiya,

    Greetings and thanks for being a great community member.

    We haven't heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is "Not resolved" in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.