Protected Content mailchimp error

Hi,
When we try to add our mailchimp API key to Protected Content and we receive the attached error. Wordpress and Protected Content are current version installs.
We are on a free Mailchimp account, not sure if a mailchimp subscription is required for API key support.

Hoping you can help.

Thank you,
Martin