Protected content page not working

I tried to search for this but all the answers were over a year ago. I set up the membership site with visitors option to see basic content. The buddypress portion of the site I wanted to be protected content. When the member is clicked as a visitor it comes up a 404 error page not the protected content page. Since only visitors are restricted I used negative rules. I think I followed instructions correctly.

The site is going to launch tomorrow evening so I don’t have any more time to play with it. I finally put the menu item for members in the negative section of the visitors and it took it out of the menu for visitors. Not exactly what I wanted as its important for visitors to actually “see” a membership area on the menu they can’t access because they aren’t members.

Can anyone help me with this?

Thanks!

  • Arun Basil Lal
    • New Recruit

    Hey Brandee,

    To fix the 404 error, please flush your permalinks:

    – Go to your WordPress Dashboard > Settings > Permalinks. Make a note of the existing Permalink settings.

    – Now set the permalinks as default and save it.

    – Now set it back to how it was and save it again.

    This should do it. Let me know.

    The trouble with the menu, was that supposed to be a solution for this one? Or is that another trouble? Please tell me more about it.

  • brandee
    • Site Builder, Child of Zeus

    OK. Thanks I’ll try that. Actually, in the process of trying anything to get this site working for deadline I put the menu in negative and it blocked it from showing at all for visitor level. It was a good solution for the time beling but not what I was looking to do. So its not really a “problem” per se just a “bandage”.

    I’ll let you know.

  • brandee
    • Site Builder, Child of Zeus

    As I said, I took the protected content out of the menu for visitors. Not a good solution to this problem. I need visitors to see what they could get if they become a member but I also can’t let them have access or have 404 pages coming up.

    I can take it out of the menu for you to see, but I can’t leave it out too long. Sometimes it takes days for a response and I can’t leave that content unprotected that long.

    Can you advise?

  • brandee
    • Site Builder, Child of Zeus

    I tried that and the buddypress pages (particularly the forum) are not protected and the other pages that are come up with the 404 error.

    I’m going to try something else but if it doesn’t work I’m thinking of I’m going to have to switch to another membership program. I really have to get this to work properly particularly since its now a live site.

  • brandee
    • Site Builder, Child of Zeus

    Here’s an update so far. I was able to protect the forum by using custom URL. However, still not able to protect the other member only pages. So instead of taking them out of the menu for visitor level, I changed the 404-page in my child theme. Still not a good option but I think a little better until I can get someone to weigh in.

  • aecnu
    • WP Unicorn

    Greetings Brandee,

    Thank you for your additional input.

    I did not read through the entire post but look to get a summary of what exactly the issue(s) is going on there and to get clarification to your statement that I was able to protect the forum by using custom URL you are referring to URL Groups?

    Please advise.

    Cheers, Joe

  • brandee
    • Site Builder, Child of Zeus

    This issue has sat here for awhile now. I didn’t think anyone was going to help me resolve it so its good to hear from you. I’m not really using url groups. In the access levels, I put the custom url of the forum to protect it.

    However, not allowing guests to access pages by putting them into the negative side doesn’t work. It keeps calling up the 404 page. I finally did a work around because I was getting a 404 page instead so I used that page to tell visitors it was protected content. I don’t know why the message for protected content is being served up. Not what I expected to have to do but until I can switch to another membership plug-in or get this one to work properly, it works.

  • aecnu
    • WP Unicorn

    Greetings Brandee,

    Thank you for your additional input and sorry for the delay in replies here.

    From what I can tell in my review of this ticket was that a Staff member replied to your ticket originally and that the ticket fell off the radar for a bit when he was …. shall we say marked inactive and no longer allowed to access the system.

    Next it appears Tom picked it up but he was brand new back then and he flagged the lead developer whom has to date as we can see has not made an appearance in here.

    Maybe we should try to get your URL Groups going?

    And investigate this 404 error?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings brandee,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that’s great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.