Protected content payment page not working

I setup the protected content plugin (went through the activation wizard) and setup paypal with IPN. However going to the register page to pay i see the price and signup button, but when clicked nothing happens. I can't register or pay? Any ideas?http://www.soundhealersassociation.org/register

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Spiritap!

    Can you please try going to Settings>Permalinks, changing to a new structure, saving, choosing your current structure, then saving again?

    I've seen this issue around the forum a few times, it looks like this is the quick fix!

    Thanks for your question, Spiritap!

  • Spiritap
    • Site Builder, Child of Zeus

    Thanks! That seemed to fix it...next problem..i paid through paypal, got returned to site but it's not giving me member access. I've waited almost an hour and still not letting me access content. When i log in as admin I don't see the new test member listed under the plugins member list.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Spiritap!

    Did you get a confirmation email for that account when you signed up? That member could be stuck in your activation queue, if you're not seeing them in the user list.

    This plugin https://wordpress.org/plugins/unconfirmed/ can help find users who've been lost in the queue, but installing it now may not catch the member you created before you installed it. Give it a try and see if you can find the user you made in the list of unconfirmed members.

    Thanks, Spiritap!

  • Spiritap
    • Site Builder, Child of Zeus

    IT appears to have added the test user as a wordpress user, but did not add them to the protected content list. THis is about the same problem I was having with your memerbship program and was told I need to convert to his program...

  • ryan
    • Site Builder, Child of Zeus

    Exactly, I notified Jack this afternoon, and he said they were going to go in and troubleshoot in the morning. This started after the last update. I was having to manually add subscribers today, sometimes they would get to where it says "pending" in the member list, and I would have to drop them from protected content and add them back in from the user list and activate them. I will let you know what they tell me tomorrow

  • Tyler Postle
    • CGO

    Hey Spirittap and Ryan,

    Can you update to the most recent version and see if this is still happening?

    I believe I remember you mentioned Ryan that you ended up adding them all individually.

    Is it users with subscriptions that aren't being added to the members list? Or just new users without a subscription, because that is default behaviour.

    Look forward to hearing back on this!

    All the best,
    Tyler

  • Spiritap
    • Site Builder, Child of Zeus

    Hello,
    Sorry got delayed with holiadys. This seems finally to be working! thank you!

    Is there a way to hide the memerbs only pages from the main menu when a guest/non logged in viewer is looking at the site? Before it honly appeared once logged in?

    Any update in adding access to bulk users?

  • aristath
    • Recruit

    Hello there @Spiritap, I hope you're well today!

    Could you please update WordPress core & all your plugins to their latest versions?
    If that does not resolve your issue could you please grant us access to your backend so that we may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    Please note that you must have the WPMU DEV Dashboard plugin installed on your site to complete the above process.

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.