Protection rules: Comments / How to set for only members read and write

Hi There

I want that only the loggued members can read and write comments but I can't figure it out how to set it up with Membership.

In Protection rules / Comments & Tags I have:
Comments: No Access => Everyone
Comments: Read Only Access => ×Member
Comments: Read and Write Access => ×Member

But with those settings Everyone can read the comments on articles. There is no protection.

Is it possible to allow only member to read and write? I mean visitors can't see comments at all.

Thanks in advance!
Best regards

  • Jude
    • DEV MAN

    Hey @schmelnitzky

    Hope you had a great weekend.

    Can you create a guest membership which applies to all non members on the site and assign that to the Comments: No Access protection

    Also a major release is out since you posted this ticket can you update to the latest version of the plugin and try again ?

    Cheers
    Jude

  • schmelnitzky
    • Design Lord, Child of Thor

    Hey Jude

    Thank you for your message.

    I didn't use the last update because I am waiting for next release. I need Last Articles protected.
    https://premium.wpmudev.org/forums/topic/membership-2-updated-no-protection-for-last-articles?replies=1#post-999185
    Just for the test now I updated the plugin and did your modifications but it still doesn't work
    Please find printscreens (it's in french "laisser un commentaire means let a comment. I did this printscreen when I was not loggued in: so I can still see the comment)

    If you indicate me how to send you logins privately I could send you the details

    Thanks in advance

  • Michael Bissett
    • Recruit

    Hey @schmelnitzky,

    Since you're wanting only members to be able to read and write comments, could you please try creating a "Default" membership (using the Default Membership type), and then after assigning that default membership to the "Comments: No Access" rule, could you then remove the rules for the "Comments: Read Only Access" & "Comments: Read and Write Access" rules?

    That should get things working for you, as you're wanting them to. :slight_smile:

    Kind Regards,
    Michael

    P.S. The "Default Membership" type is meant for those that have an account on your site, but don't belong to one of your memberships.

  • schmelnitzky
    • Design Lord, Child of Thor

    Hey Michael

    Many thanks for your answer.
    I did what you explained but it doesn't work. Please find attached my settings now but I still can see a comment when I am not loggued in.

    Hope it can be fixed. I understand in your answer that is possible which is great news :slight_smile:

  • Michael Bissett
    • Recruit

    Hey @schmelnitzky,

    Looks like you've removed the Guest Membership from the "Comments: No Access" rule as well, I'd only mentioned removing memberships from the "Comments: Read Only Access" & "Comments: Read and Write Access" rules.

    While keeping the Default Membership in the "Comments: No Access" rule, could you also add the Guest Membership back in there as well?

    If after doing that, this still isn't working as it should, could you please enable Support Access to your site? :slight_smile:

    Please advise,
    Michael

  • schmelnitzky
    • Design Lord, Child of Thor

    Thank you Michael

    Ok so I modified as you said and there is a change but it still doesn't work.
    Please find attached the print screens

    Now it says "no comments" but I still can read it

    Could you please let me know how to send you the logins in a private message there is an additional protection on the website. (PS: I have already sent the login details to Attn: Tyler Postle on 11 of december for this support request: https://premium.wpmudev.org/forums/topic/membership-2-updated-no-protection-for-last-articles?replies=1#post-999185)

    Thanks in advance

  • Michael Bissett
    • Recruit

    Hey @schmelnitzky,

    That's odd, those exact same settings not only remove the ability to comment on posts over on my own site, but it hides the comments posted there as well.

    May I ask if you've done a conflict test yet? If not, then I'd advise doing so, as it's possible that there's something interfering here, either another plugin, or perhaps the theme itself (which I noticed has an update available, I'd want to try updating too).

    We've got our handy troubleshooting flowchart available over on our Getting Support page, along with some advice on disabling plugins via FTP:

    https://premium.wpmudev.org/manuals/getting-support/

    If doing that conflict test (as well as the theme update) doesn't reveal the cause to this, then could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include site authorization details (to view the site in the first place)
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.