Provider not showing on site for a Servive

Hi. We changed some staff. We can't figure out why a service provider (me, Randy) is not appearing on the website for Lawn Care Sales Estimate. You can see here that Randy (me) is set for that Service - https://www.screencast.com/t/Asv9i0ez2Lj. If look at the same screen, Jason is set to the OTHER 2 services we offer. But when you go to http://indianrunlandscaping.com/make-an-appointment/, Jason appears for all 3 services (even the one he should NOT be part of), and Randy does not appear at all for the one needed (Lawn Care Sales Estimate). What did we do wrong?

  • Tyler Postle
    • CGO

    Hey Randy,

    The reason it's only showing Jason is because your calendar defaults to Hardscraping Sales Estimate, which only Jason does.

    If you select Lawn Care Sales Estimate and press "Show Available Times" then you will see that the provider switches to Randy since he is the only one that provides that service.

    What you might want to do is force the "Service Selection", then they will have to select the service they want before even seeing any of the availability.

    Hope that helps! If you still have further questions then could you grant support access so we can see your shortcode setup?

    You can grant support access via WPMU DEV > Support > Grant Support Access.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a great weekend :slight_smile:

    Cheers,
    Tyler

  • Randy
    • Design Lord, Child of Thor

    Thanks, I didn't know that the Choose Service Provider did not auto-refresh based on the Service (before being clicked). I don't know how to get to the screen you showed to edit that feature. Where is it?

  • Tyler Postle
    • CGO

    Sorry Randy, I should have mentioned that. You can find it on the "Visual" editor in your backend page or post editor:

    That's a shortcode generator so you will want to use the shortcode it generates to replace your existing one. If you do just the "Services" one then you will see an option to "autorefresh". Then they won't need to click the button anymore.

    Hope that helps! Cheers

  • Randy
    • Design Lord, Child of Thor

    Hmmm... there is still an issue. I tried both methods you mentioned above (and together). Right now, it is only set to Autorefresh on Services. But, here is the problem we see: when you go to the page (http://indianrunlandscaping.com/make-an-appointment/ ) the first time it default to the first service (which is fine) and it shows the one provider (Jason, which is fine). But the Calendar does not show. Even if you click Show Available Times, it does not show times. If you switch service, and then go back to Hardscaping, then it works. Why?

  • Bojan Radonic
    • Head of Support

    Hey Randy,

    Hope you don't mind me chiming in here :slight_smile:

    Reason this happens is cause these two options cancel each other. When using require_service="1" in your monthly schedule calendar is not rendered unless service is previously selected and page is refreshed so even if you click "Show available times" on your provider calendar still won't be loaded as we're requiring service to be selected.

    With having autorefresh="1" set for services you really don't need require_service="1" in your monthly schedule calendar as given that you only have 1 provider per service the correct provider will be autoselected.

    Can you please remove require_service="1" from your monthly schedule and check again? I've tested with the similar setup having 3 services and 2 providers on my sandbox site and everything worked properly.

    If this doesn't work on your end could you please grant temporary admin access as Tyler mentioned in his initial response so we can take a look?

    Hope this helps :slight_smile:

    Best regards,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.