Publicize not authenticating – Blank Page

Hadn’t tried to add any new sharing settings on my multisite until today. Also have a fair amount of plugins so I am wondering if I conflict somewhere. The sites with sharing already in place imported fine, but I cannot create a new social share. For example, I tried to add Facebook to one of my sites. Went to Settings -> Sharing and got to the page to add a social network. Clicked on Connect for FB and I just get a blank page. URL = https://public-api.wordpress.com/connect/?jetpack=publicize&service=facebook&action=request&redirect_uri=http%3A%2F%2Fnokilldenver.rescueonedog.com%2Fwp-admin%2Foptions-general.php%3Fpage%3Dsharing%26action%3Ddone&for=publicize&siteurl=http%3A%2F%2Fnokilldenver.rescueonedog.com&state=1&blog_id=39695720&secret_1=Ce3rwzRSBiM9aoEekMayYXZ0lbPA85nF&secret_2=JRoMcCqjMj5XjaQOFAax7pIzqmSebr75&eol=1467643820

But it resolves to URL without an error but jsut gives me a blank page. No sign in, no error message, nothing. Even the page source is blank.

I trtied this on multple sites with different social networks, they all do the same thing. Blank page, nothing to interact with.

I don’t have any other social plugins running but I am new to Multisite.

My Crrent plugins are:

All In One WP Security

Amazing Hover Effects

Anti-Malware Security and Brute-Force Firewall

AutoBlog

Avatars For Multisite

Network Deactivate

Blog Activity

Network Deactivate

BulletProof Security

Network Deactivate | 

Setup Wizard

Contact Form 7

Network Deactivate

Custom Google Search

Directory

Domain Mapping

Google AdSense

Google Analytics +

Jetpack by WordPress.com

MailChimp Sync

PDF Image Generator

SmartCrawl

Snapshot

UpdraftPlus – Backup/Restore

WordPress Importer

WP All Import

WP Defender

WP Hummingbird

WP Smush Pro

WPMU DEV Dashboard