published posts not displayed on front end

The most recent posts published on my site are not showing on the front end of my website for some reason. Can you help, please?
When looking at http://fetliu.net/blog/ or http://fetliu.net I don’t see the two latest posts – ‘Setting up a Blackboard Test Course’ and ‘Three Great Things About Xerte’. If you look in the admin you can see they are published, and if you search for them or find them via the tag cloud at the front end, for example, they are visible on the site.

The same problem is happening on the child sites of my network – see http://fetliu.net/babel/ . The latest post that is displayed on the front end, ‘Rejected beauty – Bennita Ciu’, was published on 10 June but three more posts have been published since then that do not appear on the front end of the site.

Is this being caused by Hummingbird Pro, maybe?

Oliver

  • Adam Czajczyk
    • Support Gorilla

    Hello oliver_haslam

    I hope you’re well today and thank you for your question!

    I see that you already confirmed that it’s happening because of caching.

    The way the Page Cache works, by its nature, is that it “prints out the page to the static file” on server and then instead of generating the page for the visitor “on the fly”, it simply reads that page that it already saved.

    That’s why it helps with performance – it’s just much easier (and, as a consequence, faster) for server to simply read a file and send it to browser rather than read a bunch of files, execute set of scripts, perform number of database queries, then put it all together and send to browser.

    However, that can also result in side-effects such as in this case. Basically, what happened was that these pages were already cached so when you added posts, those cached versions of these pages (as they were cached before that) didn’t include them.

    Two alternative ways to deal with it would be:

    1) in Page Cache settings of Hummingbird make sure that the “Clear full cache when post/page is updated” option is eanbled;

    With this setting whenever you edit or add post or page to the site, entire cache is cleared. That way all that edited/added content will be visible instantly as you’d expect it. The site will slow down a bit but only temporary – as cache will re-build itself over time. You can also speed that process up buy enabling “Preload caching” option (though if you do that, please also check if/how that impacts your server resource load).

    2) Alternatively, instead of above solution you can set “Clear cache on interval” option in “Page Cache” settings. In such case site will still be cached and if you edit/add content, it will not be visible instantly but will only show up after the cache is automatically cleared up (e.g. every 3 days or 2 hours etc, depending on how you set that). Again, once cache is cleared, the site might slow down temporarily but the cache should get re-built and site would speed up again.

    Both these ways should work fine but which one’s better for you depends mostly on how “time sensitive” your content is and how often you change/add it. If it’s important for these posts to show up immediately, the first way would be better.

    Yet another option would be to actually exclude some pages from cache entirely while keeping cache enabled – but I’d only recommend this if none of the two ways mentioned above work for you. That’s because if you exclude given page (e.g. homepage) from cache it will be showing all the posts right away but will be “permanently slower”. I think though the 1st way should work fine for you.

    If you have any additional questions, let me know, please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.