Publishing on Facebook failed

Created and set-up perfectly, then last week when I go and create a new post and tick the box to post to facebook, I get "Publishing on Facebook failed" - all my granted permissions seem fine. Any ideas?

  • markshipperley
    • New Recruit

    Hi Phil,

    I have my personal page and my business page, some strange things are happening to the drop down box for the plugin. I can see post to the wall of this account (me) and also my business page(Mark Shipperley Films) I can also see the the app I created for the plugin. Hit update post and I receive the error, I have noticed that on the plugin drop down box now only has (me) in the list. I have tried to post logged into facebook and also logged out and also using page as me and as "Mark Shipperley Films" Thanks again

    Mark

  • Philip John
    • DEV MAN’s Apprentice

    Hmm that does seem strange.

    Can you try to go through the steps again with a new Facebook app? I'm wondering if there was something about the way you originally set it up that was wrong. Setting it up again with a new app will tell us if it's Facebook or the plugin.

    Phil

  • markshipperley
    • New Recruit

    Hi Phil,

    Recreated app, went through ultimate facebook plugin set-up, all looked OK can see my 3 pages"ME, Mark Shipperley films & New APP" on the post page drop down. Hit update with post to facebook ticked and receive same error. The drop down box then just has (ME) in it and I have to refresh page to get (Mark Shipperley Films) back. Tried logged into facebook under ME & Mark Shipperley films, same error.
    Logged out of facebook and can only see (ME) under drop down list on post page.

    Since I deleted the old app I have lost my facebook wall posts which were created using the plugin.

    Thanks

    Mark

  • DavidM
    • DEV MAN’s Mascot

    Hi markshipperley,

    While we're awaiting the developer, if you could provide us with a screenshot of the settings you've got for the auto-posting, that would definitely help us to see what's going on. If you're auto-posting right from the post editor, if you could also get us a screenshot of the settings you're using there, that would be great.

    Also, is anything else working with the plugin? The Like/Send buttons, Facebook login, widgets, etc? Have you tried anything else, and if not, could you give it a try to see how that all works?

    Lastly, could you let us know which versions of WordPress and Ultimate Facebook you're using?

    Thanks,
    David

  • geoclicks
    • New Recruit

    I seem to have this same problem and am not sure where to start.

    Here's what I've done.

    1) setup wordpress 3.2.1
    2) installed buddypress
    3) installed this plugin (version 1.2.2 from lib/and set it up, including grant all permissions.

    PHp version is 5.3.8, https handler, curl and json are enabled

    When I try to post from the back end, I do get the Publishing on Facebook failed error.

  • geoclicks
    • New Recruit

    FYI - Modified post_on_facebook and printed the exception and the $post variable that was getting passed to it.

    Turns out the problem is with an invalid "picture".

    Went back to the plugin settings and added a default image under the opengraph settings and it worked.

    Might be best to check if there is no default set, to perhaps not set the "picture" variable in the array.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.