Purchased PopOver Pro, nonfunctional JS error

I'm totally at the end of my rope. We used the last version of PopOver (free) for a while, updated it as I was supposed to and went ahead and purchased "Pro" since we liked the plugin, and now, no pop ups will work. Not new ones, not pre-existing ones. And of course, we HAD to have a popup this morning for a high-traffic article. I'm really bummed that this didn't work straight out of the box.

Here's what I tried:
I cleared the entire browser cache and all cookies, tried it on multiple browsers, upgraded to the latest WP (4.0), and shut off every other plugin to no avail. When it's supposed to pop up, I get a JavaScript error saying undefined is not a function in file "public.min.js?ver=4.0". Just to test it, I set the popup timer to ten seconds. After 10, that's the error. I tried all four "Load PopUp Using"s with no change. JS error pops up every time. I should also add that I tried it both signed out and signed in, and the Preview DOES function as expected in the admin "edit popup" section.

The silly stuff: There's no conditions (like coming from an outside site), the popover IS activated and SHOULD show up, and when it's supposed to, it doesn't. We're using a pretty straightforward theme and I've run out of any ideas at this point.

Again, this worked with the last version and since the upgrade, is not functioning at all. And we absolutely had to have a popup today. I'm really disheartened. Please help!

  • Michelle Shull

    Hi Matt!

    Oh no! I'm happy to help you get PopUp running the way you want it to.

    The good news: there isn't a known bug that causes this issue, so we should be able to suss it up and get it going quickly.

    Let me start with the simple, forgive me if you already tried this, but PopUp is a revamp of the previous plugin, is there any chance that older version is still active on your site? The two running together would definitely cause this conflict. PopUp Pro will grab all your pre-made pop ups, so there's no worries you'll lose any data if one is deactivated.

    Second, I see you've already done a lot of early troubleshooting, that's great, and really helpful. Can you link me to a page where the pop up should be showing, so I can run some tests?

    Thanks!

  • Michelle Shull

    Hi Matt.

    We answer questions in the order they're submitted, from oldest first, after the initial response. Sometimes, when we're slammed, it can take longer to get back through to the top of the feed for us to respond.

    I'm actually not able to get your site to load it all, is that also the case for you?

    If you can get into your admin area, can you allow support access? If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks!

  • Michelle Shull

    Hi, Matt!

    I've looked over your site pretty thoroughly, and I can't find what's causing this issue for your. Your settings are all fine, there are no other plugins running that might conflict (to the best of my knowledge, sometimes conflicts sneak up on us.), and your site works fine, otherwise.

    I made a test pop-up (deleted when done) that also didn't work. Checked the alternative loading methods (with Ajax) and that didn't help. Tried with and without AdBlocker active. This should work, there's no reason I can see why it isn't working. There's a tiny conflict with your theme with the footer loading method, but nothing that should interfere with any of the other methods. Curious, this is.

    I am at a loss, so I'm going to bump this to second level support. Sometimes it can take a little longer to get a reply, that team is very busy, and pretty small.

    Thanks for your patience while we help you track this down.

  • Matt

    Well, thank you Michelle. I appreciate you looking into this. Just as a quick reference, it shouldn't be any other plugins. We did troubleshoot and shut off all other plugins and try it.

    We're motivated to do ANYTHING to get this working, and we're happy to give the team almost any sort of access that's needed on about any level. This represents a big key part of our campaign that's supposed to be currently running, so we're very anxious to resolve this.

    And as one other point of reference, we DID have the old (free) version of the popup and that <i>did</i> work fine -- but it did NOT work with <b>one</b> of the loading methods, to the best of my memory. It was the javascript loading method, I believe. The default. That was the old one. New one doesn't work at all. What's changed between then and now is that not only did we upgrade to the new (paid) version, but we also did update the new Wordpress and any dated plugins.

  • Philipp Stracker

    Hi @Matt!

    Sorry to hear that our plugin causes you troubles... I have just taken a look at your site to get to the ground of this problem.

    We did find multiple javascript errors on the page (see the screenshot below)
    But most importantly the theme seems outdated - I think the version you use was released around 2010 and loads its own version of jQuery which replaces the WordPress jQuery version.
    Naturally the themes jQuery version is also from 2010 and heavily outdated...

    Also the Arras theme loads its own version of jQuery which is not WordPress conform anymore: WordPress comes with its own jQuery files that are loaded, and when the theme loads another version of jQuery there are conflicts, and in this case possibly the old jQuery code is not compatible with your plugins, including the PopUp Pro plugin.

    I suggest to:
    - Switch to the default theme twentyfourteen to test (if possible, just for 1 minute)
    - Update the Arras theme to the current version (which is from 2012)

    If there are still errors then
    - Make sure only 1 veryion of jQuery is loaded.
    - We should investigate the first error in more detail (which is not caused by some other plugin) - as the first javascript error that happens often breaks all scripts that are executed afterwards.

    Let us know if the update did solve the issue or if you need help with anything!
    Thanks, Philipp

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.