"Pushing" changes via the site options control not taking effect

Hey guys, the option to force a template on a network site isn't functioning for me. Here's the deal:

-I go to Sites under Super Admin
-Get the Edit option by mousing over the path of the site I want to access.
-Go to the Edit screen. (So that we all know what page I'm on, the Site Info control is on the right of the screen and the Site Themes control is on the left).
-Under Misc Site Actions, I see the template dropdown. I choose the template I want to force to the site and click the Update Options button.
-The page refreshes and the Setting Saved yellow dialog box appears at the top, but the changes do not show on the site and the Template dropdown on the Edit page still reads None.

Any ideas? I've verified that I'm editing the site I think I am.

Lastly, I'd like to put in a vote for the feature discussed here: https://premium.wpmudev.org/forums/topic/new-blog-template-multiple-templates-themes. Would make my life massively easier.

Thank you much!

  • Mason

    Hiya!

    First off, welcome to WPMU DEV! Glad you're here!

    Sorry about the slower response time on this one, but I wanted to setup a new install and test this out before responding.

    I can confirm this issue in my own tests and will let the devs know about it. One of them should be able to come by and leave a comment as to what the correct functionality is here.

    To be honest, I didn't even know that this was an available option. The New Blog Template plugin is meant for creating new blogs - not editing them once they've been made. Not that this functionality can't work, just surprised to even see it in there.

    Also, thanks for your vote for multiple template selection. We'll take a look at this again. We've got loads of ideas, updates, and features on the horizon, so this probably won't make it in the next batch of updates.

    Thanks again for your feedback!

  • Aaron

    To be honest, I didn't even know that this was an available option. The New Blog Template plugin is meant for creating new blogs - not editing them once they've been made. Not that this functionality can't work, just surprised to even see it in there.

    Ditto here. Apparently that is some leftover code that was started by our original dev, but is incomplete, nonfunctional and unsupported. Also unfortunately we have no plans to add that functionality. The technical issues with it were too problematic.

    Note that this plugin is designed for one purpose, to apply a default template to new blogs as they are being created.