Q and A layout in Catalyst theme framework

Have installed Q&A which works fine using default (twentyten) theme. However, on installing the theme I want to use - a child theme of the Catalyst framework the questions all appear but with no other page elements (no header, sidebars etc).

Not sure if it is helpful but the single.php file in Catalyst contains nothing other than: <? php catalyst_framework ();

I will also ask on the Catalyst forum but any suggestions here would be welcome.

  • Philip John
    • DEV MAN’s Apprentice

    Not sure if it is helpful but the single.php file in Catalyst contains nothing other than: <? php catalyst_framework ();

    It's certainly not helpful of the Catalyst developers!

    Obviously it's a premium theme so kinda difficult for us to test without purchasing. If you could let us have admin access to your installation we could take a look.

    However, I suspect it's just a case of identifying the conflicting CSS rules and ironing them out, which Catalyst might be best to help with.

    Let me know what you want to do.

    Phil

  • ChrisMc
    • Site Builder, Child of Zeus

    Ok, so an easy solution in the end. Just a case of replacing the header, sidebar, footer etc functions so for example in the case of catalyst
    <?php get_header( 'question' ); ?> in the top of the template files gets replaced with
    `<?php catalyst_head ( 'question' ); ?>

    and so on

    Many thanks for the great plugins.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.