Q and A plugin is causing 500 error in a site after WordPress recent update

Hi,

Q&A plugin is causing serious problems to my sites after most recent WordPress 4.5 update.
Sites that are activated this plugins gives 500 error and can not be accessed. This plugin was the culprit after my investigation. When the plugin is deactivated from a sub site in a multiste, the site is back otherwise its not accessible at all.

Also I notice these in the error log:

Notice: The called constructor method for WP_Widget in QA_Widget_Questions is deprecated since version 4.3.0! Use

Notice: The called constructor method for WP_Widget in QA_Widget_Tags is deprecated since version 4.3.0! Use

Notice: The called constructor method for WP_Widget in QA_Widget_Categories is deprecated since version 4.3.0! Use

Notice: The called constructor method for WP_Widget in QA_Widget_Reputation is deprecated since version 4.3.0! Use

__construct()

Please provide a solution to this problem immediately!
I have enabled support access. You can test out this behavior in my Test sub-site.

Thanks.