Q&A and Design

In the original release of the Q&A plugin I put up some screen shots showing how it didn't work with the side bar. Just ran your update and now its having a different affect in themes.

1 Screen shows a Q&A page the other shows a page how it should look. I don't seem to have these issues with other plugins.

  • LPH
    • Site Builder, Child of Zeus

    I've spent a little time with this plugin and was able to resolve the sidebar issues with adding some css for the theme and a sidebar-question.php file in the theme root.

    In another post here, someone was also stating there was a problem and the dev provided a custom css for the qa-page-wrapper.

    In general.css, you'll find the following.

    #qa-page-wrapper {
    float: left;
    overflow: hidden;
    width: 620px;
    padding-bottom: 2em;
    }

    You will want to adjust accordingly. Hope this helps.

  • Timothy Bowers
    • Chief Pigeon

    If the issue wasn't resolved within the plugin and required work on every release I wouldn't go to the trouble of editing the CSS of every theme on the off chance a user might use that theme and plugin in our install.

    I'd rather it work out of the box with all themes or just not use it.

    Thanks for the pointer though, I haven't had time recently to play and look the code as much as usual. :slight_smile:

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Tim,

    Could we get a URL to the site in those screenshots?

    If not, could you provide the following so we can see exactly where things are going wrong?:

    Using Firebug, or similar, can you paste details of the styles affecting that central, white content area for both the normal page and Q&A page?

    This should give us an idea of where the Q&A plugin either is over-riding theme CSS or missing out on theme styling.

    Cheers,
    Phil

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Tim,

    I've looked high and low and can't find your e-mail, sorry :slight_frown:

    I see a couple from you but nothing relating to this thread. Did you send it direct to David? We use a combination of personal and combined inboxes so I suspect it may have gotten lost amongst David's filters (we have a LOT of e-mails so this can happen).

    Your best bet is always to send through the contact form with "Attn [name]" in the subject field to ensure it gets to the right person.

    So, if you'd like to use the contact form to do that I'll be sure to make sure either myself, David or Mason pick it up and run with it.

    Cheers,
    Phil

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Tim,

    Okay it looks like it just needs an archive template created for the questions. This theme seems to push everything to very specific template files. It allows for better customisation but does make it a bit more complicated to just add custom post types in.

    I can't test it out right now but once I can I'll see if I can get it working myself. If you get chance first let me know how you get on!

    Phil

  • aecnu
    • WP Unicorn

    Greetings networkcities,

    Welcome to WPMU Dev!

    Luckily I was in the back of the ticket system digging around when I came across your response to not only a ticket that was closed four months ago but also monitored by a technician that has been gone also as long.

    Please do not be offended that I ask you to open your own ticket and feel free to copy and paste your question form here so that we can get a current tech assigned on a current ticket and it is not lost in the back of the system with you perhaps thinking that we are ignoring you - because that certainly is not the case.

    Sincerely, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.