Q&A: Clicking 'Register / Login' results in error page

Hello,

I wrote about this a couple weeks ago, but it was as part of a longer list of issues with our implementation of the Q&A plugin and fell off the radar.

When you visit this page (http://www.drgreene.com/askdrgreene/tonsil-stones/), for instance, and click on 'Register / Login and Submit' when the form is *blank* you get this message on an error page (I wrote the error message):

'Well clearly something has gone wrong here. We've been notified and are on the case.

If you would like to contact us about this issue, shoot us an email ...'

I've run this test while evaluating our PHP error logs and nothing shows up, so I'm not sure where to start looking.

If I enter a single character, the form submits, and I get take to the register page.

A side issue is that even if I don't complete registration, my answer is accepted on to the page. This should obviously be resolved as well.

Where should I start looking to resolve the blank form submission issue?

Thanks,
Paul

  • Ash

    Hello @Cheryl

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    This error message is produced by your theme (or any other plugin) that overwrite the Q&A's error message. Would you please quickly activate the default wp 2012 theme and check the page? The error message should be like:

    Questions must have both a title and a body. Please use your browser's back button to edit your question.

    Please let me know.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.