Q&A Plugin - does it work with the latest wordpress update 3.5.1?

Q&A Plugin - does it work with the latest wordpress update 3.5.1?