Q&A plugin error on Ask a Question

When clicking on Ask A Question (either logged in or not), I receive an error (attached). The site is running at the root url. Please help.

  • Sajid
    • DEV MAN’s Sidekick

    Hi david_london,
    Hope you are doing good today :slight_smile:

    Its look like you have installed a security plugin and have restricted the wp-admin area that is causing issue here. Could you please run a plugin or theme conflict test as described in getting support manual. This basic step will help us figure out the problem quickly and efficiently.

    If the issue still there then please grant support staff access so I can take a closer look and troubleshoot. During troubleshooting, I will be deactivating plugins and switching theme to default. To grant access go to WPMU DEV -> Support -> Support Access -> Grant Access or see this manual.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Panos
    • SLS

    Hello david_london ,

    This message looks like content from a robots.txt file. Are you aware of any changes in files wp-config.php or .htaccess?

    It seems that something is overriding default behaviour. You can try deactivating plugin and you will notice that the /questions/ask page doesn't show the 404 not found page but it redirects to home page.

    Any information would be useful in order to get to the bottom of this. If you have not made any changes, could you provide ftp access so we can investigate your files closer?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question?" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:Subject: "Attn: Panos Lyrakis"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Before sharing ftp credentials I would recommend to keep a backup first.

    I would also need your approval to disable any plugins or switch theme for a while. Looking forward to your reply!

    Kind regards,
    Panos

  • david_london
    • WPMU DEV Initiate

    My site is down. Are you editing the files currently? I was going in to backup the database.
    Please contact me direct if you are. Clients were looking at the development today and are freaking out that it's gone. I haven't touched the files since Monday.

  • david_london
    • WPMU DEV Initiate

    The site is back up now. Problem is that the two original WPMU issues are still there. The Login Redirect plugin is not redirecting to the page it's supposed to after Membership 2 login. And the Q&A plugin still breaks when you click on Ask a Question (http://www.globalmobilityroundtable.com/questions/). I get this error message still:
    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php

    Please let me know if you need any other FTP info, login info, or links.

  • Panos
    • SLS

    Hey david_london ,

    I noticed that there is no .htaccess file and I don't have permissions to create one.

    Could you create it and insert the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Thanks!
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.