Q&A plugin errors in debug mode

Hi

In debug mode on my wordpress v3.8 site the Q&A plugin is throwing up the below errors. Please could you let me know if it's an incompatibility between the new version of wordpress or if there's a conflict with custom code:

Deprecated: Function split() is deprecated in /Applications/MAMP/htdocs/green_kartel/wp-content/plugins/qa/core/edit.php on line 180

Notice: Undefined property: stdClass::$site_name in /Applications/MAMP/htdocs/green_kartel/wp-content/plugins/qa/core/subscriptions.php on line 88

Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/green_kartel/wp-content/plugins/qa/core/edit.php:180) in /Applications/MAMP/htdocs/green_kartel/wp-includes/pluggable.php on line 896

It is also showing the following error in the WP backend (image attached):

Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /Applications/MAMP/htdocs/green_kartel/wp-includes/functions.php on line 3049

Thanks for your help

  • aristath
    • Recruit

    Hello there @paul, I hope you're well today!

    These are simple PHP notices, nothing to worry about. They do not interfere with the functionality of the plugin and as soon as you set WP_DEBUG to false again they will disappear.

    However I have notified the plugin developer about this so that we may take care of this in the next plugin release.

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.