QA Plugin Integration Questions

Hello, I purchased an account (really just for this plugin) and I've installed the plugin (QA) but I have a few questions that I've been unable to find answers to and hoping you can help. We're running the latest version of wordpress with our own custom theme and we're not running buddypress. Thanks in advance for any help. I know this is a long thread but I'd really like to use the plugin and continue my membership.

1) How does QA notify the person that asked the question, as to when someone answers? We installed and tested the plugin but it didnt seem to notify us when an answer was submitted.

2) On the demo that you have for this plugin, I noticed a few things that I couldn't figure out how to implement on my theme. For example... on our implementation, when a user is not logged in, and they visit a page with a question, there's no prompt to answer whereas on the demo, there is a answer box that says "login and submit" at the bottom of the box. Is there a theme call we need to make or something we need to add to our theme to have this enabled? Additionally, on the demo, there's a "profile" for each person that's involved (site.com/questions/user/username). However, on our site, those profile links merely redirect to the site homepage. Is there something additional to do in order to get those profiles to show or is that something that's only compatible with buddypress? You can see that on our test site, where we do NOT have buddypress, a link to the author profile still shows, but redirects to the homepage of the site. here's an example question page so you can see what I mean - http://onlineinvideo.com/questions/why-doesnt-marks-internet-work-very-well/

3) Lastly, Is there anyway to allow users to reply to answers or add comments to answers and have them be threaded?

Thanks again in advance for the help

  • aecnu

    Greetings reelseo,

    Welcome to WPMU Dev!

    1) How does QA notify the person that asked the question, as to when someone answers? We installed and tested the plugin but it didnt seem to notify us when an answer was submitted.

    Edit: Good question which I missed this posting. I will work on the answer as I await your answer to the below items.

    2) On the demo that you have for this plugin, I noticed a few things that I couldn't figure out how to implement on my theme. For example... on our implementation, when a user is not logged in, and they visit a page with a question, there's no prompt to answer whereas on the demo, there is a answer box that says "login and submit" at the bottom of the box. Is there a theme call we need to make or something we need to add to our theme to have this enabled?

    It is my opinion that the problems of which boxes are available and which are may be directly related to the choices made for the levels as set in site dashboard --> Questions --> Settings --> Assign Capabilities --> in this case the Visitor level. When I chose to NOT allow visitors to answer questions is when i no longer see the editor box nor the "login and submit" at the bottom of the box.
    Screen shots 1 and 2 below, visitor no permission to answer and then permission to answer respectively.

    Additionally, on the demo, there's a "profile" for each person that's involved (site.com/questions/user/username). However, on our site, those profile links merely redirect to the site homepage. Is there something additional to do in order to get those profiles to show or is that something that's only compatible with buddypress?

    No that it does not need Buddy Press and the profile works just fine on my test site on our production servers even though I am using the Grid Market theme for Market Press .... lol:
    http://aecnuwpmu.us/questions/

    You can see that on our test site, where we do NOT have buddypress, a link to the author profile still shows, but redirects to the homepage of the site. here's an example question page so you can see what I mean - http://onlineinvideo.com/questions/why-doesnt-marks-internet-work-very-well/

    Oh yes I see what you mean, and it looks like you folks have a lot of plugins installed or Buddy Press since many of those items on the menu are Buddy Press components or or plugins serving a similar purpose. Therefore it is my opinion you need to go through a complete trouble shooting session to find out which plugin is interfering with the profile link and redirecting to the main page instead of the profile.

    First I would reset the permalinks then if that does not fix it do the trouble shooting.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if none exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    3) Lastly, Is there anyway to allow users to reply to answers or add comments to answers and have them be threaded?

    Not that I am aware of.

    Please advise on how you folks make out with setting the correct permissions for visitors and regarding the profile URL redirect being incorrect if resetting the permalinks fixed it or what plugin(s) are causing the conflict.

    Look forward to hearing for you and thank you for being a WPMU Dev Member!

    Cheers, Joe

  • aecnu

    Greetings reelseo,

    I admit I am at a loss as to why you are having this issue and I have even set my test production server site to the Twenty Eleven theme just to see if I can reproduce this issue, and I cannot:
    http://aecnuwpmu.us/questions/

    It is now time to call in the big guns, the lead developer to see if he can spot any possible reason this may be happening and possibly offer advice/advise on how to mitigate this issue.

    Though this may take longer then a normal ticket, I will try to get his invaluable advice/advise in here asap.

    Cheers, Joe

  • aecnu

    Greetings reelseo,

    Thank you for your feedback, it is greatly appreciated.

    I would think that if it were indeed the theme that when you changed to Twenty Eleven that possibility would no longer be part of the equation.

    You did not mention what theme you are using?

    And is your htaccess file indeed permission-ed 666 for when your changing the permalinks?

    Sorry to hear that to date we are unable to get around whatever the issue may be.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings reelseo,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • reelseo

    Thanks for being so proactive. Feel free to close the thread because I put the project on hold - I just ran into too many issues and put things on hold on our end. I'm sure I'll get back to it someday when I have more time to figure it all out. I really should just hire a wordpress expert to help me with it cause I think I'll need some customization as well but not sure where to begin with all of that. Thanks again for the proactive support.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.